Error in 3.2.4 on startup, service not found (rspamd milter)

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

Error in 3.2.4 on startup, service not found (rspamd milter)

TG Servers
Hi,

I am getting the following error messages when starting up postfix 3.2.4

2018-02-17T21:50:34.594521+01:00 ms2 postfix/cleanup[9220]: fatal:
host/service localhost/11332 not found: Name or service not known

2018-02-17T21:50:35.594843+01:00 ms2 postfix/pickup[8886]: warning:
maildrop/4612EA0DCA: error writing 90F5AA0EB0: queue file write error

2018-02-17T21:50:35.595321+01:00 ms2 postfix/master[8885]: warning:
process /usr/libexec/postfix/cleanup pid 9220 exit status 1

2018-02-17T21:50:35.595521+01:00 ms2 postfix/master[8885]: warning:
/usr/libexec/postfix/cleanup: bad command startup -- throttling

Ther should be rspamd running as a milter on 11332 but I see it
listening on 0.0.0.0?

tcp        0      0 0.0.0.0:11332           0.0.0.0:*
LISTEN      4420/rspamd: main p

tcp        0      0 127.0.0.1:11333         0.0.0.0:*
LISTEN      4420/rspamd: main p

The postfix configuration looks like that :
smtpd_milters = inet:localhost:11332
non_smtpd_milters = inet:localhost:11332
milter_protocol = 6

Can you please help with that?

Thanks.


Reply | Threaded
Open this post in threaded view
|

Re: Error in 3.2.4 on startup, service not found (rspamd milter)

TG Servers
I had a typo in my config it it now listening on 127.0.0.1:11332 but I
am getting the same startup errors actually.

Am 17.02.2018 um 21:57 schrieb TG Servers:

> Hi,
>
> I am getting the following error messages when starting up postfix 3.2.4
>
> 2018-02-17T21:50:34.594521+01:00 ms2 postfix/cleanup[9220]: fatal:
> host/service localhost/11332 not found: Name or service not known
>
> 2018-02-17T21:50:35.594843+01:00 ms2 postfix/pickup[8886]: warning:
> maildrop/4612EA0DCA: error writing 90F5AA0EB0: queue file write error
>
> 2018-02-17T21:50:35.595321+01:00 ms2 postfix/master[8885]: warning:
> process /usr/libexec/postfix/cleanup pid 9220 exit status 1
>
> 2018-02-17T21:50:35.595521+01:00 ms2 postfix/master[8885]: warning:
> /usr/libexec/postfix/cleanup: bad command startup -- throttling
>
> Ther should be rspamd running as a milter on 11332 but I see it
> listening on 0.0.0.0?
>
> tcp        0      0 0.0.0.0:11332           0.0.0.0:*
> LISTEN      4420/rspamd: main p
>
> tcp        0      0 127.0.0.1:11333         0.0.0.0:*
> LISTEN      4420/rspamd: main p
>
> The postfix configuration looks like that :
> smtpd_milters = inet:localhost:11332
> non_smtpd_milters = inet:localhost:11332
> milter_protocol = 6
>
> Can you please help with that?
>
> Thanks.
>
>
Reply | Threaded
Open this post in threaded view
|

Re: Error in 3.2.4 on startup, service not found (rspamd milter)

Wietse Venema
In reply to this post by TG Servers
TG Servers:

> Hi,
>
> I am getting the following error messages when starting up postfix 3.2.4
>
> 2018-02-17T21:50:34.594521+01:00 ms2 postfix/cleanup[9220]: fatal:
> host/service localhost/11332 not found: Name or service not known
>
> 2018-02-17T21:50:35.594843+01:00 ms2 postfix/pickup[8886]: warning:
> maildrop/4612EA0DCA: error writing 90F5AA0EB0: queue file write error
>
> 2018-02-17T21:50:35.595321+01:00 ms2 postfix/master[8885]: warning:
> process /usr/libexec/postfix/cleanup pid 9220 exit status 1
>
> 2018-02-17T21:50:35.595521+01:00 ms2 postfix/master[8885]: warning:
> /usr/libexec/postfix/cleanup: bad command startup -- throttling
>
> Ther should be rspamd running as a milter on 11332 but I see it
> listening on 0.0.0.0?
>
> tcp        0      0 0.0.0.0:11332           0.0.0.0:*
> LISTEN      4420/rspamd: main p
>
> tcp        0      0 127.0.0.1:11333         0.0.0.0:*
> LISTEN      4420/rspamd: main p
>
> The postfix configuration looks like that :
> smtpd_milters = inet:localhost:11332
> non_smtpd_milters = inet:localhost:11332
> milter_protocol = 6
>
> Can you please help with that?

Perhasps you have read http://www.postfix.org/DEBUG_README.html,
and looked at the CHROOT feature?

        Wietse
Reply | Threaded
Open this post in threaded view
|

Re: Error in 3.2.4 on startup, service not found (rspamd milter)

Benny Pedersen-2
In reply to this post by TG Servers
TG Servers skrev den 2018-02-17 22:45:
> I had a typo in my config it it now listening on 127.0.0.1:11332 but I
> am getting the same startup errors actually.

milter_rspamd = inet:[localhost]:11332

non_smtp_milters = $milter_rspamd
smtpd_milters = $milter_rspamd

and lastly why is localhost unknown host ?

if thats not working yet, replace localhost inside []

make sure rspamd listen to both ::1 and 127.0.0.1 or just one of them
:=)

tip if its binded to both localhost should work
Reply | Threaded
Open this post in threaded view
|

Re: Error in 3.2.4 on startup, service not found (rspamd milter)

TG Servers
In reply to this post by Wietse Venema
Ok thanks will turn off all chroots and go stepwise forward.... tomorrow

Thanks

Am 17.02.2018 um 23:42 schrieb Wietse Venema:

> TG Servers:
>> Hi,
>>
>> I am getting the following error messages when starting up postfix 3.2.4
>>
>> 2018-02-17T21:50:34.594521+01:00 ms2 postfix/cleanup[9220]: fatal:
>> host/service localhost/11332 not found: Name or service not known
>>
>> 2018-02-17T21:50:35.594843+01:00 ms2 postfix/pickup[8886]: warning:
>> maildrop/4612EA0DCA: error writing 90F5AA0EB0: queue file write error
>>
>> 2018-02-17T21:50:35.595321+01:00 ms2 postfix/master[8885]: warning:
>> process /usr/libexec/postfix/cleanup pid 9220 exit status 1
>>
>> 2018-02-17T21:50:35.595521+01:00 ms2 postfix/master[8885]: warning:
>> /usr/libexec/postfix/cleanup: bad command startup -- throttling
>>
>> Ther should be rspamd running as a milter on 11332 but I see it
>> listening on 0.0.0.0?
>>
>> tcp        0      0 0.0.0.0:11332           0.0.0.0:*
>> LISTEN      4420/rspamd: main p
>>
>> tcp        0      0 127.0.0.1:11333         0.0.0.0:*
>> LISTEN      4420/rspamd: main p
>>
>> The postfix configuration looks like that :
>> smtpd_milters = inet:localhost:11332
>> non_smtpd_milters = inet:localhost:11332
>> milter_protocol = 6
>>
>> Can you please help with that?
>
> Perhasps you have read http://www.postfix.org/DEBUG_README.html,
> and looked at the CHROOT feature?
>
> Wietse
>
Reply | Threaded
Open this post in threaded view
|

Re: Error in 3.2.4 on startup, service not found (rspamd milter)

TG Servers
In reply to this post by Benny Pedersen-2
It's binded to both, the problem seems to be somewhere in chrooting as
Wietse already supposed, will try that tomorrow

Am 17.02.2018 um 23:48 schrieb Benny Pedersen:

> TG Servers skrev den 2018-02-17 22:45:
>> I had a typo in my config it it now listening on 127.0.0.1:11332 but I
>> am getting the same startup errors actually.
>
> milter_rspamd = inet:[localhost]:11332
>
> non_smtp_milters = $milter_rspamd
> smtpd_milters = $milter_rspamd
>
> and lastly why is localhost unknown host ?
>
> if thats not working yet, replace localhost inside []
>
> make sure rspamd listen to both ::1 and 127.0.0.1 or just one of them :=)
>
> tip if its binded to both localhost should work