Extremely slow active queue

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Extremely slow active queue

Dennis Jacobfeuerborn
Hi,
I have trouble with mails getting delayed in the active queue of a postfix
2.2 installation. The problem is that mails appear in the active queue and
then get stuck there for 10 minutes before getting delivered to the
mailbox. When sending a test mail there were only 4 mails in the queue and
over the next 10 minutes only a hand full of new mails arrived yet it still
took the testmail 10 minutes to move from the queue to the mailbox so it's
not a congestion issue. This is a single-machine setup using virtual
mailboxes. What could cause this?

Regards,
   Dennis
Reply | Threaded
Open this post in threaded view
|

Re: Extremely slow active queue

Wietse Venema
Dennis Jacobfeuerborn:
> Hi,
> I have trouble with mails getting delayed in the active queue of a postfix
> 2.2 installation. The problem is that mails appear in the active queue and
> then get stuck there for 10 minutes before getting delivered to the
> mailbox. When sending a test mail there were only 4 mails in the queue and
> over the next 10 minutes only a hand full of new mails arrived yet it still
> took the testmail 10 minutes to move from the queue to the mailbox so it's
> not a congestion issue. This is a single-machine setup using virtual
> mailboxes. What could cause this?

This could have any number of causes, ranging from a file server
with a broken clock, to a horribly mis-configured mail system.

Without concrete evidence no progress will be made on this.

        Wietse

The mailing list welcome message says:

TO REPORT A PROBLEM see http://www.postfix.org/DEBUG_README.html#mail

TO (UN)SUBSCRIBE see http://www.postfix.org/lists.html

Thank you for using Postfix.