Jessie - Stretch to jump on Postfix 3.x

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Jessie - Stretch to jump on Postfix 3.x

Maurizio Caloro-2

Hello Together

 

I’am running with Debain Jessie 8.9, i play with the ideea upgrade the system 8.9 ->Stretch.

Please existing here any complication, or/after the upgrade i need to reconfigure the hole mailserver?

 

I see that Stretch are armed with Postfix 3.x

 

I know this are not a specific Postfix question, but i am intressed to hear your expiriences!

 

Regards

Mauri

 

Reply | Threaded
Open this post in threaded view
|

RE: Jessie - Stretch to jump on Postfix 3.x

L.P.H. van Belle
for me it was a good and easy upgrade from jessie to stretch.
 
Things i needed  to change/run was this : 
 
# for postfix
postconf compatibility_level=2 && postfix reload
 
# for ntp
 sed -i 's/restrict -4 default kod notrap nomodify nopeer noquery/restrict -4 default kod notrap nomodify nopeer noquery limited/g' /etc/ntp.conf
 sed -i 's/restrict -6 default kod notrap nomodify nopeer noquery/restrict -6 default kod notrap nomodify nopeer noquery limited/g' /etc/ntp.conf
 
and i did not like all language messages with apt. update in my logs ( own repo )
 
if [ ! -e /etc/apt/apt.conf.d/99disable-translations ]; then
    echo "Adding disable translations for apt"
    echo "Acquire::Languages \"none\";" > /etc/apt/apt.conf.d/99disable-translations
else
 echo "No modication needed (apt disable-translations)"
fi
 
but thats about it.
 
Good luck in upgrading, and this was for me, for you it may be different, that depends on the packages used.
 
 
Greetz,
Louis
 


Van: [hidden email] [mailto:[hidden email]] Namens Maurizio Caloro
Verzonden: dinsdag 17 oktober 2017 10:40
Aan: 'Postfix Users'
Onderwerp: Jessie - Stretch to jump on Postfix 3.x

Hello Together

 

I’am running with Debain Jessie 8.9, i play with the ideea upgrade the system 8.9 ->Stretch.

Please existing here any complication, or/after the upgrade i need to reconfigure the hole mailserver?

 

I see that Stretch are armed with Postfix 3.x

 

I know this are not a specific Postfix question, but i am intressed to hear your expiriences!

 

Regards

Mauri

 

Reply | Threaded
Open this post in threaded view
|

Re: Jessie - Stretch to jump on Postfix 3.x

Dominic Raferd
For postfix it will be easy enough, just study http://www.postfix.org/COMPATIBILITY_README.html.

I went from Ubuntu 14.04 (based on jessie and uses postfix 2.x) to 16.04 (based on stretch, uses postfix 3.x) a while ago, I had a few problems relating to the change from upstart/sysinitv to systemd, but I think Jessie (plain) already uses systemd by default so you won't have that hurdle to jump. 

Also for amavisd-new I had to change permission of /var/lib/spamassassin directory to 755 - an alternative (untested by me) is to make user amavis a member of debian-spamd group.