MY virtual_mailbox_aliases aren't working ...

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

MY virtual_mailbox_aliases aren't working ...

Shaun T. Erickson
I have a configuration of:

#
# Virtual mailbox domain support
#
virtual_mailbox_domains = /etc/postfix/virtual_mailbox_domains
virtual_mailbox_maps = hash:/etc/postfix/virtual_mailbox_recipients
virtual_alias_maps = hash:/etc/postfix/virtual_mailbox_aliases
virtual_mailbox_base = /opt/vmail
virtual_minimum_uid = 100
virtual_uid_maps = static:5000
virtual_gid_maps = static:5000

#
# virtual_mailbox_domains
#
example.net

#
# virtual_mailbox_recipients
#
[hidden email]       example.net/shaun/INBOX

#
# virtual_mailbox_aliases
#
[hidden email]  [hidden email]

Mail sent to [hidden email] works, without issue.

Mail sent to [hidden email] fails, with postfix reporting that
the user [hidden email] doesn't exist.

What am I doing wrong?

--
 -ste
Reply | Threaded
Open this post in threaded view
|

Re: MY virtual_mailbox_aliases aren't working ...

Wietse Venema
What is the output of:

$ postconf virtual_alias_maps

What is the output of:

$ postmap -s /etc/postfix/virtual_mailbox_aliases

        Wietse
Reply | Threaded
Open this post in threaded view
|

Re: MY virtual_mailbox_aliases aren't working ...

Shaun T. Erickson
On Fri, May 2, 2008 at 12:52 PM, Wietse Venema <[hidden email]> wrote:
> What is the output of:
>
>  $ postconf virtual_alias_maps
>
>  What is the output of:
>
>  $ postmap -s /etc/postfix/virtual_mailbox_aliases

[root@cg postfix]# postconf virtual_alias_maps
virtual_alias_maps = hash:/etc/postfix/virtual_mailbox_aliases

[root@cg postfix]# postmap -s /etc/postfix/virtual_mailbox_aliases
[hidden email] [hidden email]
[hidden email] [hidden email]
[hidden email] [hidden email]
[hidden email] [hidden email]
[root@cg postfix]#

None of those aliases work. I am assuming I have done something wrong,
somewhere.
--
 -ste
Reply | Threaded
Open this post in threaded view
|

Re: MY virtual_mailbox_aliases aren't working ...

Wietse Venema
Shaun T. Erickson:

> On Fri, May 2, 2008 at 12:52 PM, Wietse Venema <[hidden email]> wrote:
> > What is the output of:
> >
> >  $ postconf virtual_alias_maps
> >
> >  What is the output of:
> >
> >  $ postmap -s /etc/postfix/virtual_mailbox_aliases
>
> [root@cg postfix]# postconf virtual_alias_maps
> virtual_alias_maps = hash:/etc/postfix/virtual_mailbox_aliases
>
> [root@cg postfix]# postmap -s /etc/postfix/virtual_mailbox_aliases
...
> None of those aliases work. I am assuming I have done something wrong,
> somewhere.

In that case you have receive_override_options in main.cf or in
master.cf.

        Wietse
Reply | Threaded
Open this post in threaded view
|

Re: MY virtual_mailbox_aliases aren't working ...

Shaun T. Erickson
On Fri, May 2, 2008 at 1:27 PM, Wietse Venema <[hidden email]> wrote:
>
>  In that case you have receive_override_options in main.cf or in
>  master.cf.

[root@cg postfix]# grep receive main.cf
smtpd_tls_received_header = yes
[root@cg postfix]# grep receive master.cf
[root@cg postfix]#

It would seem not.
--
 -ste
Reply | Threaded
Open this post in threaded view
|

Re: MY virtual_mailbox_aliases aren't working ...

Wietse Venema
Shaun T. Erickson:

> On Fri, May 2, 2008 at 1:27 PM, Wietse Venema <[hidden email]> wrote:
> >
> >  In that case you have receive_override_options in main.cf or in
> >  master.cf.
>
> [root@cg postfix]# grep receive main.cf
> smtpd_tls_received_header = yes
> [root@cg postfix]# grep receive master.cf
> [root@cg postfix]#
>
> It would seem not.

Did you look in master.cf for other command-line options, such as
options that override your virtual_alias_maps setting?

I can lead the horse to the water but I can't force it to drink.

        Wietse
Reply | Threaded
Open this post in threaded view
|

Re: MY virtual_mailbox_aliases aren't working ...

James-368

> I can lead the horse to the water but I can't force it to drink.

Your horse is broken. :-)