OSX 10.15.5 #error "Unsupported Berkeley DB version"

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

OSX 10.15.5 #error "Unsupported Berkeley DB version"

rachalmers
Trying to build 3.5.3 on OSX 10.15.5 and running into this problem again.

dict_db.c:768:2: error: "Unsupported Berkeley DB version"
#error "Unsupported Berkeley DB version”

Build script.

make -f Makefile.init dynamicmaps=yes CCARGS='-I/usr/local/Cellar/berkeley-db/18.1.32_1/include -DHAS_MYSQL -I/usr/local/include/mysql -DUSE_TLS -DUSE_SASL_AUTH -DUSE_CYRUS_SASL -I/opt/local/include/sasl -DDEF_SERVER_SASL_TYPE=\"dovecot\" -DHAS_PCRE -I/opt/local/include -DEF_COMMAND_DIR=\"/usr/local/sbin\" -DEF_CONGIG_DIR=\"/usr/local/etc/postfix\" -DEF_DAEMON_DIR=\"/usr/local/libexec/postfix\" -DEF_DATA_DIR=\"/var/lib/postfix\" -DEF_MAILQ_PATH=\"/usr/local/bin/mailq\" -DEF_HTML_DIR=\"/usr/share/doc/postfix/html\" -DEF_MANPAGE_DIR=\"/usr/local/man\" -DEF_NEWALIAS_PATH=\"/usr/local/bin/newaliases\" -DEF_QUEUE_DIR=\"/private/var/spool/postfix\" -DEF_README_DIR=\"/usr/share/doc/postfix\" -DEF_SENDMAIL_PATH=\"/usr/local/sbin/sendmail\"' 'AUXLIBS=-L/usr/lib -lsasl2 -L/usr/local/opt/openssl/lib -lssl -lcrypto -L/usr/local/Cellar/berkeley-db/18.1.32_1/lib -ldb' 'AUXLIBS_IUUC=-L/usr/local/Cellar/icu4c/62.1/lib -licuuc' 'AUXLIBS_MYSQL=-L/usr/local/lib -lmysqlclient -lz -lm' 'AUXLIBS_PCRE=-L/usr/local/lib -lpcre’

Does anyone have any ideas please. I can find nothing relevant out there that I didn’t already writ myself - and now trying to update the server, I’m falling over this again.

Thanks
Robert

Reply | Threaded
Open this post in threaded view
|

Re: OSX 10.15.5 #error "Unsupported Berkeley DB version"

Wietse Venema
Robert Chalmers (Author):
> Trying to build 3.5.3 on OSX 10.15.5 and running into this problem again.
>
> dict_db.c:768:2: error: "Unsupported Berkeley DB version"
> #error "Unsupported Berkeley DB version?

What has changed since the last successful build?  All Postfix 3.x
releases support the same Berkeley DB version numbers.

        Wietse

> Build script.
>
> make -f Makefile.init dynamicmaps=yes CCARGS='-I/usr/local/Cellar/berkeley-db/18.1.32_1/include -DHAS_MYSQL -I/usr/local/include/mysql -DUSE_TLS -DUSE_SASL_AUTH -DUSE_CYRUS_SASL -I/opt/local/include/sasl -DDEF_SERVER_SASL_TYPE=\"dovecot\" -DHAS_PCRE -I/opt/local/include -DEF_COMMAND_DIR=\"/usr/local/sbin\" -DEF_CONGIG_DIR=\"/usr/local/etc/postfix\" -DEF_DAEMON_DIR=\"/usr/local/libexec/postfix\" -DEF_DATA_DIR=\"/var/lib/postfix\" -DEF_MAILQ_PATH=\"/usr/local/bin/mailq\" -DEF_HTML_DIR=\"/usr/share/doc/postfix/html\" -DEF_MANPAGE_DIR=\"/usr/local/man\" -DEF_NEWALIAS_PATH=\"/usr/local/bin/newaliases\" -DEF_QUEUE_DIR=\"/private/var/spool/postfix\" -DEF_README_DIR=\"/usr/share/doc/postfix\" -DEF_SENDMAIL_PATH=\"/usr/local/sbin/sendmail\"' 'AUXLIBS=-L/usr/lib -lsasl2 -L/usr/local/opt/openssl/lib -lssl -lcrypto -L/usr/local/Cellar/berkeley-db/18.1.32_1/lib -ldb' 'AUXLIBS_IUUC=-L/usr/local/Cellar/icu4c/62.1/lib -licuuc' 'AUXLIBS_MYSQL=-L/usr/local/lib -lmysqlclient -lz -lm' 'AUXLIBS_PCRE=-L/usr/local/lib -lpcre??
>
> Does anyone have any ideas please. I can find nothing relevant out there that I didn?t already writ myself - and now trying to update the server, I?m falling over this again.
>
> Thanks
> Robert
>
>
Reply | Threaded
Open this post in threaded view
|

Re: OSX 10.15.5 #error "Unsupported Berkeley DB version"

Viktor Dukhovni
In reply to this post by rachalmers
On Fri, Jun 26, 2020 at 01:39:19PM +0100, Robert Chalmers (Author) wrote:
> Trying to build 3.5.3 on OSX 10.15.5 and running into this problem again.
>
> dict_db.c:768:2: error: "Unsupported Berkeley DB version"
> #error "Unsupported Berkeley DB version”

On my laptop I have "homebrew", and the Berkeley DB I end up linking to
is:

    ... -I/usr/local/opt/db/include -L/usr/local/opt/db/lib -ldb ...

with:

    /usr/local/opt/db -> ../Cellar/berkeley-db/6.2.32

--
    Viktor.