Postfix with no SASL: build problems

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Postfix with no SASL: build problems

Tom Browder
In another thread we discussed having TLS but no SASL.

I have tried the latest experimental Postfix and have dropped back to
using v3.2.2.

I am using this configuration:

  make makefiles CCARGS="-DUSE_TLS -DNO_IP_CYRUS_SASL_AUTH"

I am using the Debian 8 (wheezy) openssl which is 1.0.1t.

During the build I get lines like this:

[src/smtpd]
gcc -I. -I../../include -DUSE_TLS -DNO_IP_CYRUS_SASL_AUTH -DNO_EAI
-DDEF_SMTPUTF8_ENABLE=\"no\" -DHAS_DEV_URANDOM -DHAS_PCRE
-I/usr/local/include -UUSE_DYNAMIC_LIBS -DDEF_SHLIB_DIR=\"no\"
-UUSE_DYNAMIC_MAPS -Wmissing-prototypes -Wformat -Wno-comment -g -O
-I. -I../../include -DLINUX3  -o smtpd smtpd.o smtpd_token.o
smtpd_check.o smtpd_chat.o smtpd_state.o smtpd_peer.o
smtpd_sasl_proto.o smtpd_sasl_glue.o smtpd_proxy.o smtpd_xforward.o
smtpd_dsn_fix.o smtpd_milter.o smtpd_resolve.o smtpd_expand.o
smtpd_haproxy.o ../../lib/libmaster.a ../../lib/libtls.a
../../lib/libxsasl.a ../../lib/libmilter.a ../../lib/libdns.a
../../lib/libglobal.a ../../lib/libutil.a -L/usr/local/lib -lpcre -ldb
-lnsl -lresolv -ldl
../../lib/libtls.a(tls_session.o): In function `tls_session_stop':
/usr/local/src/postfix-3.2.2/src/tls/tls_session.c:101: undefined
reference to `SSL_shutdown'
/usr/local/src/postfix-3.2.2/src/tls/tls_session.c:103: undefined
reference to `SSL_shutdown'
../../lib/libtls.a(tls_session.o): In function `tls_session_passivate':
/usr/local/src/postfix-3.2.2/src/tls/tls_session.c:123: undefined
reference to `i2d_SSL_SESSION'
/usr/local/src/postfix-3.2.2/src/tls/tls_session.c:135: undefined
reference to `i2d_SSL_SESSION'
../../lib/libtls.a(tls_session.o): In function `tls_session_activate':
/usr/local/src/postfix-3.2.2/src/tls/tls_session.c:162: undefined
reference to `d2i_SSL_SESSION'
../../lib/libtls.a(tls_server.o): In function `new_server_session_cb':
/usr/local/src/postfix-3.2.2/src/tls/tls_server.c:272: undefined
reference to `SSL_get_ex_data'
/usr/local/src/postfix-3.2.2/src/tls/tls_server.c:275: undefined
reference to `SSL_SESSION_get_id'
/usr/local/src/postfix-3.2.2/src/tls/tls_server.c:276: undefined
reference to `SSLeay'
/usr/local/src/postfix-3.2.2/src/tls/tls_server.c:296: undefined
reference to `SSL_SESSION_free'
<snip>
collect2: error: ld returned 1 exit status
Makefile:77: recipe for target 'smtpd' failed
make: *** [smtpd] Error 1
Makefile:92: recipe for target 'update' failed
make: *** [update] Error 1

The complete log can be seen at:

  https://gist.github.com/tbrowder/daaba1fb99c1c4ef2671ddefc3e2d6f6

Thanks for any help.

Best regards,

-Tom
Reply | Threaded
Open this post in threaded view
|

Re: Postfix with no SASL: build problems

Tom Browder
On Thu, Aug 17, 2017 at 1:13 PM, Tom Browder <[hidden email]> wrote:
> In another thread we discussed having TLS but no SASL.
>
> I have tried the latest experimental Postfix and have dropped back to
> using v3.2.2.

Please disregard, this "problem" which I'm pretty sure I caused.

I'll report the solution when I verify that.

-Tom
Reply | Threaded
Open this post in threaded view
|

Re: Postfix with no SASL: build problems

Tom Browder

On Thu, Aug 17, 2017 at 14:08 Tom Browder <[hidden email]> wrote:
On Thu, Aug 17, 2017 at 1:13 PM, Tom Browder <[hidden email]> wrote:
> In another thread we discussed having TLS but no SASL.
>
> I have tried the latest experimental Postfix and have dropped back to
> using v3.2.2.

Please disregard, this "problem" which I'm pretty sure I caused.

I'll report the solution when I verify that.

My problem was a typo in my confit script which had extra quotes inserted in a long line broken with a backslash which resulted in some necessary lib and include lines being ignored.

The latest experimental postfix built and installed fine and I am now getting it configured for my needs.

FWIW: System is Debian 8, 64-bit.

-Tom