RE: can't get server to start postfix --ISSUE RESOLVED

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

RE: can't get server to start postfix --ISSUE RESOLVED

Fazzina, Angelo

Hi again, thanks for the pointers everyone.

It was not a Postfix issue. I have no idea how it happened but permissions on / got changed some how.

 

This fixed the default Postfix install, and then I put my config in and we are running normally again.

 

root@mail2 ~]# ls -ld /

drw-------. 23 root root 4096 Sep  8 09:59 /

 

 

[root@mail2 ~]# chmod 555 /

[root@mail2 ~]# ls -ld /

dr-xr-xr-x. 23 root root 4096 Sep  8 09:59 /

 

 

Server was rebooted

 

[root@mail2 ~]# ps -ef | grep post

root      1821     1  0 10:15 ?        00:00:00 /usr/libexec/postfix/master

postfix   1827  1821  0 10:15 ?        00:00:00 pickup -l -t fifo -u

postfix   1828  1821  0 10:15 ?        00:00:00 qmgr -l -t fifo -u

root      2637  2609  0 10:15 pts/0    00:00:00 grep post

 

Sadly I did not figure it out a co-worker did, but at least production services are running again.

With Dovecot and other things running I was convinced it was not the server still and a postfix issue….

Thanks again for all that tried to help.

-ALF

 

-Angelo Fazzina

Operating Systems Programmer / Analyst

University of Connecticut,  UITS, SSG, Server Systems

860-486-9075

 

 

-----Original Message-----
From: [hidden email] [mailto:[hidden email]] On Behalf Of Viktor Dukhovni
Sent: Friday, September 8, 2017 10:17 AM
To: [hidden email]
Subject: Re: can't get server to start postfix

 

 

> On Sep 8, 2017, at 10:07 AM, Fazzina, Angelo <[hidden email]> wrote:

>

> I ran

> Yum remove postfix

> I moved any directories not deleted

> I have SELinux disabled  in /etc/sysconfig/

>

> I ran yum install postfix.

>

> Still same error, this is crazy.

 

You're not providing actionable information.  Does the "ls -ld"

command still report alternative access control for any of

the directories on the path from the root to

"/var/lib/postfix/master.lock"?

 

If so, master(8) likely still gets "Permission" denied when trying

to open the lock file.

 

Either you're wrong and SELinux is not disabled, or as Wietse

suggested there could be filesystem corruption, or there are

inherited access controls in place down from /var, etc.

 

You can test whether the restriction is still in place by giving

the "postfix" user a shell of "/bin/sh", then:

 

   # su postfix

   $ touch /var/lib/postfix/master.lock # Likely fails

   $ echo $$ > /var/lib/postfix/master.lock   # Likely fails

 

Fixing SELinux and broken filesystems is not a subject matter

for Postfix experts, best to ask on some forum dedicated for

your O/S, or just hunker down and figure it out.  Come back

to this list when the Postfix user has full rights to the

/var/lib/postfix/ directory.

 

--

              Viktor.