SASL auth not working

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

SASL auth not working

Emmett Culley
I am not able to get postfix to authenticate on port 465 or 587 to allow account holders to relay via this server.  

Everything else works.  That is, we can use the account name and password to log into Cyrus IMAP, though I know it
isn't postfix that makes that connection, it does mean that SASL is working and accepts the mail account creds used
in all the tests in the attachment.

Thunderbird is set up to user SSL/TLS with normal password on port 465 for outgoing email.

It looks to me like postfix is not getting a positive response from SASL, so I expect something is not configured correctly.  I've spent the last two days trying to find the issue and have run out of ideas.  Any help would be appreciated.

Regards,
  Emmett


postfix (19K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: SASL auth not working

Viktor Dukhovni
On Sun, Apr 15, 2018 at 01:26:54PM -0700, Emmett Culley wrote:

> smtpd_sasl_path = smptd
>
> -- listing of /etc/sasl2 --
> -rw-rw-r--    1 root root   49 Apr 15 07:10 smtpd.conf
>
> -- content of /etc/sasl2/smtpd.conf --
> pwcheck_method: saslauthd
> mech_list: plain login

Look closely.

--
        Viktor.
Reply | Threaded
Open this post in threaded view
|

Re: SASL auth not working

Emmett Culley
On 04/15/2018 01:31 PM, Viktor Dukhovni wrote:

> On Sun, Apr 15, 2018 at 01:26:54PM -0700, Emmett Culley wrote:
>
>> smtpd_sasl_path = smptd
>>
>> -- listing of /etc/sasl2 --
>> -rw-rw-r--    1 root root   49 Apr 15 07:10 smtpd.conf
>>
>> -- content of /etc/sasl2/smtpd.conf --
>> pwcheck_method: saslauthd
>> mech_list: plain login
>
> Look closely.
>
Gah!  I actually broke that while trying other changes.  Thanks for the very quick response.  All work as expected now.

Emmett