Unmeant update from 2.2.10 to 2.5.1

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Unmeant update from 2.2.10 to 2.5.1

Jens Mueller-2
hi all,

on my server runs Ubuntu and last weekend I started an update on my system.
By this step my Postfix was updated from 2.2.10 to 2.5.1 and now it hangs.
Das ganze läuft in Verbindung mit MySQL und SpamAssassin.

The configuration was unchanged!
The mail.err says:

May  5 17:41:28 vinola1 postfix/pipe[1739]: fatal: user= command-line attribute specifies mail system postdrop group id 112

Thanks for any help.

Best regards,
Jens

[...]
#
# ====================================================================
# Interfaces to non-Postfix software. Be sure to examine the manual
# pages of the non-Postfix software to find out what options it wants.
#
# Many of the following services use the Postfix pipe(8) delivery
# agent.  See the pipe(8) man page for information about ${recipient}
# and other message envelope options.
# ====================================================================
#
# maildrop. See the Postfix MAILDROP_README file for details.
# Also specify in main.cf: maildrop_destination_recipient_limit=1
#
maildrop  unix  -       n       n       -       -       pipe
flags=R user=vmail argv=/usr/bin/maildrop -d ${recipient}
#
# See the Postfix UUCP_README file for configuration details.
#
uucp      unix  -       n       n       -       -       pipe
flags=Fqhu user=uucp argv=uux -r -n -z -a$sender - $nexthop!rmail ($recipient)
#
# Other external delivery methods.
#
ifmail    unix  -       n       n       -       -       pipe
flags=F user=ftn argv=/usr/lib/ifmail/ifmail -r $nexthop ($recipient)
bsmtp     unix  -       n       n       -       -       pipe
flags=Fq. user=bsmtp argv=/usr/lib/bsmtp/bsmtp -t$nexthop -f$sender $recipient
scalemail-backend unix  -       n       n       -       2       pipe
flags=R user=scalemail argv=/usr/lib/scalemail/bin/scalemail-store ${nexthop} ${user} ${extension}
mailman   unix  -       n       n       -       -       pipe
flags=FR user=list argv=/usr/lib/mailman/bin/postfix-to-mailman.py
${nexthop} ${user}
spamassassin unix -     n       n       -       -       pipe
      user=spamd argv=/usr/bin/spamc -f -e
      /usr/sbin/sendmail -oi -f ${sender} ${recipient}




Reply | Threaded
Open this post in threaded view
|

Re: Unmeant update from 2.2.10 to 2.5.1

mouss-2
Jens Mueller wrote:

> hi all,
>
> on my server runs Ubuntu and last weekend I started an update on my system.
> By this step my Postfix was updated from 2.2.10 to 2.5.1 and now it hangs.
> Das ganze läuft in Verbindung mit MySQL und SpamAssassin.
>
> The configuration was unchanged!
> The mail.err says:
>
> May  5 17:41:28 vinola1 postfix/pipe[1739]: fatal: user= command-line attribute
> specifies mail system postdrop group id 112
>  

do not share groups. do not put vmail, spamd and/or list in the
"postdrop" group.


> Thanks for any help.
>
> Best regards,
> Jens
>
> [...]
> #
> # ====================================================================
> # Interfaces to non-Postfix software. Be sure to examine the manual
> # pages of the non-Postfix software to find out what options it wants.
> #
> # Many of the following services use the Postfix pipe(8) delivery
> # agent.  See the pipe(8) man page for information about ${recipient}
> # and other message envelope options.
> # ====================================================================
> #
> # maildrop. See the Postfix MAILDROP_README file for details.
> # Also specify in main.cf: maildrop_destination_recipient_limit=1
> #
> maildrop  unix  -       n       n       -       -       pipe
> flags=R user=vmail argv=/usr/bin/maildrop -d ${recipient}
> #
> # See the Postfix UUCP_README file for configuration details.
> #
> uucp      unix  -       n       n       -       -       pipe
> flags=Fqhu user=uucp argv=uux -r -n -z -a$sender - $nexthop!rmail ($recipient)
> #
> # Other external delivery methods.
> #
> ifmail    unix  -       n       n       -       -       pipe
> flags=F user=ftn argv=/usr/lib/ifmail/ifmail -r $nexthop ($recipient)
> bsmtp     unix  -       n       n       -       -       pipe
> flags=Fq. user=bsmtp argv=/usr/lib/bsmtp/bsmtp -t$nexthop -f$sender $recipient
> scalemail-backend unix  -       n       n       -       2       pipe
> flags=R user=scalemail argv=/usr/lib/scalemail/bin/scalemail-store ${nexthop}
> ${user} ${extension}
> mailman   unix  -       n       n       -       -       pipe
> flags=FR user=list argv=/usr/lib/mailman/bin/postfix-to-mailman.py
> ${nexthop} ${user}
> spamassassin unix -     n       n       -       -       pipe
>       user=spamd argv=/usr/bin/spamc -f -e
>       /usr/sbin/sendmail -oi -f ${sender} ${recipient}
>
>
>
>
>  

Reply | Threaded
Open this post in threaded view
|

Re: Unmeant update from 2.2.10 to 2.5.1

Wietse Venema
In reply to this post by Jens Mueller-2
Jens Mueller:
> May_ 5 17:41:28 vinola1 postfix/pipe[1739]: fatal: user= command-line
> attribute specifies mail system postdrop group id 112

As documented, you MUST NOT use the postfix user and group IDs
for non-postfix commands.

Specifically, in master.cf, you MUST NOT specify a "user=xxx"
attribute that has the group ID of the postdrop group.

        Wietse