Xserve running Mac OS X

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

Xserve running Mac OS X

The Doctor
Right I have the following colocated box with
the following configuration:


$postconf -n
command_directory = /usr/sbin
config_directory = /etc/postfix
content_filter = smtp-amavis:[127.0.0.1]:10024
daemon_directory = /usr/libexec/postfix
debug_peer_level = 2
enable_server_options = yes
header_checks = regexp:/etc/postfix/header_checks
home_mailbox = Mailbox
html_directory = no
local_recipient_maps = unix:passwd.byname $alias_maps
mail_owner = _postfix
mailbox_command = /usr/bin/procmail
mailbox_size_limit = 0
mailbox_transport = cyrus
mailq_path = /usr/bin/mailq
manpage_directory = /usr/share/man
message_size_limit = 1048576000
mydestination = $myhostname,localhost.$mydomain,localhost,$mydomain,mail.$mydomain,www.$mydomain,ftp.$mydomain
mydomain = vstudios.ca
mydomain_fallback = localhost
myhostname = mail.vstudios.ca
mynetworks = 204.209.81.19/32, 127.0.0.0/8, 208.118.93.0/24
newaliases_path = /usr/bin/newaliases
queue_directory = /private/var/spool/postfix
readme_directory = /usr/share/doc/postfix
relayhost = $mydomain
sample_directory = /usr/share/doc/postfix/examples
sendmail_path = /usr/sbin/sendmail
setgid_group = _postdrop
smtpd_enforce_tls = no
smtpd_pw_server_security_options = login,plain
smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination,permit
smtpd_sasl_auth_enable = yes
smtpd_tls_cert_file = /etc/certificates/Default.crt
smtpd_tls_key_file = /etc/certificates/Default.key
smtpd_use_pw_server = yes
smtpd_use_tls = yes
transport_maps = hash:/etc/postfix/transport
unknown_local_recipient_reject_code = 550
virtual_alias_domains = innovationsmusic.com visionarycollege.ab.ca visionaryentertainment.ca camprockstar.ca futuresfest.com muse-musicunites.com
virtual_alias_maps = hash:/etc/mail/virtual                  


The DNS are pointing to this box as MX and when I do a local
test, no log nor delivery is
taking place.

What do I need to fix?

--
Member - Liberal International This is [hidden email]
Ici [hidden email] God, Queen and country! Beware Anti-Christ rising!
Never Satan President Republic!
The fool says in his heart, "There is no God". They are corrupt, and their ways are vile; there is no one who does good. - Ps 53:1
Reply | Threaded
Open this post in threaded view
|

Re: Xserve running Mac OS X

Victoriano Giralt-2
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

The Doctor escribió:
| Right I have the following colocated box with
| the following configuration:

8<-----8<
removed extra info
8<-----8<
| mydomain = vstudios.ca
| mydomain_fallback = localhost
| myhostname = mail.vstudios.ca
8<-----8<
more noise
8<-----8<

| The DNS are pointing to this box as MX and when I do a local
| test, no log nor delivery is
| taking place.
|
| What do I need to fix?
|
Probably the connection to the machine:
;; QUESTION SECTION:
;visionaryentertainment.ca.     IN      MX

;; ANSWER SECTION:
visionaryentertainment.ca. 3600 IN      MX      5 mail.vstudios.ca.
visionaryentertainment.ca. 3600 IN      MX      10 doctor.nl2k.ab.ca.

;; AUTHORITY SECTION:
visionaryentertainment.ca. 3600 IN      NS      ns2.nl2k.ab.ca.
visionaryentertainment.ca. 3600 IN      NS      doctor.nl2k.ab.ca.

Then:
[vic@atila ~]$ telnet mail.vstudios.ca 25
Trying 69.42.58.100...
Connected to mail.vstudios.ca (69.42.58.100).
Escape character is '^]'.
220-hp10.hostpapa.com ESMTP Exim 4.69 #1 Wed, 19 Aug 2009 18:53:44 -0400
220-We do not authorize the use of this system to transport unsolicited,
220 and/or bulk e-mail.
quit
221 hp10.hostpapa.com closing connection
Connection closed by foreign host.

That is clearly not Postfix, or it is very well disguised  :)

- --
Victoriano Giralt
Systems Manager
Central ICT Services
University of Malaga
SPAIN
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.5 (GNU/Linux)
Comment: Using GnuPG with CentOS - http://enigmail.mozdev.org

iD8DBQFKjINSV6+mDjj1PTgRAjqKAJsFf/vCYDB82EwU52mXvoAQCEqEnwCfco/O
EiQ7gOCql0nYRlEJ6IHbP1I=
=1tX3
-----END PGP SIGNATURE-----
Reply | Threaded
Open this post in threaded view
|

Re: Xserve running Mac OS X

The Doctor
On Thu, Aug 20, 2009 at 12:57:24AM +0200, Victoriano Giralt wrote:

> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
>
> The Doctor escribió:
> | Right I have the following colocated box with
> | the following configuration:
>
> 8<-----8<
> removed extra info
> 8<-----8<
> | mydomain = vstudios.ca
> | mydomain_fallback = localhost
> | myhostname = mail.vstudios.ca
> 8<-----8<
> more noise
> 8<-----8<
>
> | The DNS are pointing to this box as MX and when I do a local
> | test, no log nor delivery is
> | taking place.
> |
> | What do I need to fix?
> |
> Probably the connection to the machine:
> ;; QUESTION SECTION:
> ;visionaryentertainment.ca.     IN      MX
>
> ;; ANSWER SECTION:
> visionaryentertainment.ca. 3600 IN      MX      5 mail.vstudios.ca.
> visionaryentertainment.ca. 3600 IN      MX      10 doctor.nl2k.ab.ca.
>
> ;; AUTHORITY SECTION:
> visionaryentertainment.ca. 3600 IN      NS      ns2.nl2k.ab.ca.
> visionaryentertainment.ca. 3600 IN      NS      doctor.nl2k.ab.ca.
>
> Then:
> [vic@atila ~]$ telnet mail.vstudios.ca 25
> Trying 69.42.58.100...
> Connected to mail.vstudios.ca (69.42.58.100).
> Escape character is '^]'.
> 220-hp10.hostpapa.com ESMTP Exim 4.69 #1 Wed, 19 Aug 2009 18:53:44 -0400
> 220-We do not authorize the use of this system to transport unsolicited,
> 220 and/or bulk e-mail.
> quit
> 221 hp10.hostpapa.com closing connection
> Connection closed by foreign host.
>
> That is clearly not Postfix, or it is very well disguised  :)
>

Right, on the Xserve that will be vstudios.ca we have


mail.vstudios.ca 25
Trying 204.209.81.19...
Connected to mail.vstudios.ca.
Escape character is '^]'.
220 mail.vstudios.ca ESMTP Postfix    


> - --
> Victoriano Giralt
> Systems Manager
> Central ICT Services
> University of Malaga
> SPAIN
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1.4.5 (GNU/Linux)
> Comment: Using GnuPG with CentOS - http://enigmail.mozdev.org
>
> iD8DBQFKjINSV6+mDjj1PTgRAjqKAJsFf/vCYDB82EwU52mXvoAQCEqEnwCfco/O
> EiQ7gOCql0nYRlEJ6IHbP1I=
> =1tX3
> -----END PGP SIGNATURE-----

--
Member - Liberal International This is [hidden email]
Ici [hidden email] God, Queen and country! Beware Anti-Christ rising!
Never Satan President Republic!
The fool says in his heart, "There is no God". They are corrupt, and their ways are vile; there is no one who does good. - Ps 53:1
Reply | Threaded
Open this post in threaded view
|

Re: Xserve running Mac OS X

Brian Evans - Postfix List
In reply to this post by The Doctor
The Doctor wrote:
> Right I have the following colocated box with
> the following configuration:
>
>
> $postconf -n
>
> mailbox_command = /usr/bin/procmail
> mailbox_transport = cyrus
>  

mailbox_transport takes precidence over mailbox_command.. so procmail is
never called by Postfix

> relayhost = $mydomain
>  
Remove this.  It may cause mail loops.
It's purpose is the default, next-hop destination of mail NOT meant for
your machine.
> The DNS are pointing to this box as MX and when I do a local
> test, no log nor delivery is
> taking place.
>
> What do I need to fix?
>
>  

Logging is done by your system via syslog calls.
Postfix does not log directly.

Without logs, we cannot tell what is going on.
Reply | Threaded
Open this post in threaded view
|

Re: Xserve running Mac OS X

The Doctor
On Thu, Aug 20, 2009 at 10:38:42AM -0400, Brian Evans - Postfix List wrote:

> The Doctor wrote:
> > Right I have the following colocated box with
> > the following configuration:
> >
> >
> > $postconf -n
> >
> > mailbox_command = /usr/bin/procmail
> > mailbox_transport = cyrus
> >  
>
> mailbox_transport takes precidence over mailbox_command.. so procmail is
> never called by Postfix
>
> > relayhost = $mydomain
> >  
> Remove this.  It may cause mail loops.
> It's purpose is the default, next-hop destination of mail NOT meant for
> your machine.
> > The DNS are pointing to this box as MX and when I do a local
> > test, no log nor delivery is
> > taking place.
> >
> > What do I need to fix?
> >
> >  
>
> Logging is done by your system via syslog calls.
> Postfix does not log directly.
>
> Without logs, we cannot tell what is going on.

One moment I got:

tail /var/log/mail.log
Aug 20 21:44:28 Xserve-002436F349EE postfix/postfix-script[57707]: fatal: the Postfix mail system is not running
Aug 20 21:44:31 Xserve-002436F349EE postfix/postfix-script[57710]: fatal: the Postfix mail system is not running
Aug 20 21:44:31 Xserve-002436F349EE postfix/postfix-script[57713]: fatal: the Postfix mail system is not running
Aug 20 21:44:32 Xserve-002436F349EE postfix/postfix-script[57716]: fatal: the Postfix mail system is not running
Aug 20 21:44:34 Xserve-002436F349EE postfix/postfix-script[57718]: fatal: usage: postfix start (or stop, reload, abort, flush, check, set-permissions, upgrade-configuration)
Aug 20 21:44:37 Xserve-002436F349EE postfix/master[57766]: fatal: open lock file pid/master.pid: unable to set exclusive lock: Resource temporarily unavailable
Aug 20 21:44:47 Xserve-002436F349EE postfix/master[57768]: fatal: open lock file pid/master.pid: unable to set exclusive lock: Resource temporarily unavailable
Aug 20 21:44:57 Xserve-002436F349EE postfix/master[57779]: fatal: open lock file pid/master.pid: unable to set exclusive lock: Resource temporarily unavailable
Aug 20 21:45:07 Xserve-002436F349EE postfix/master[57782]: fatal: open lock file pid/master.pid: unable to set exclusive lock: Resource temporarily unavailable

--
Member - Liberal International This is [hidden email]
Ici [hidden email] God, Queen and country! Beware Anti-Christ rising!
Never Satan President Republic!
The fool says in his heart, "There is no God". They are corrupt, and their ways are vile; there is no one who does good. - Ps 53:1