aquamail connecting to postfix

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

aquamail connecting to postfix

David Mehler
Hello,

Does anyone have Android's aquamail app successfully connecting to a
Postfix server? If so, w hat settings did you use? I keep getting an
authentication denied error. I've tried for authentication choose
automatically, sasl plain, sasl login. For server security I've tried
ssl strict check, ssl accept any (both on port 465), and starttls
strict check and starttls accept any (port 587).

Thanks.
Dave.
Reply | Threaded
Open this post in threaded view
|

Re: aquamail connecting to postfix

John Allen

I have AquaMail working on a S7edge running Lineageos 14.1 (have had it working on vanilla samsung touchwiz). My setting are:

  • imap
    • server: imap.klam.ca
    • security type - SSL (strict check)
    • server port: 993
    • authentication:chose automatically
    • login: xxxxx
    • password:
    • folder prefix: automatic
  • smtp
    • security type: Starttls(strict check)
    • server port: 587
    • authentication: choose automatically
    • login:
    • password:

this works for me

best of luck

john a


On 2018-02-11 06:12 PM, David Mehler wrote:
Hello,

Does anyone have Android's aquamail app successfully connecting to a
Postfix server? If so, w hat settings did you use? I keep getting an
authentication denied error. I've tried for authentication choose
automatically, sasl plain, sasl login. For server security I've tried
ssl strict check, ssl accept any (both on port 465), and starttls
strict check and starttls accept any (port 587).

Thanks.
Dave.

Reply | Threaded
Open this post in threaded view
|

Re: aquamail connecting to postfix

Voytek
In reply to this post by David Mehler
I don't use it, but just tried setting up,
worked out of the box with IMAP StartTLS 143 and SMTP StartTLS 587

Now, I'll try to send this...


On 12 February 2018 10:13:50 AM David Mehler <[hidden email]> wrote:

> Hello,
>
> Does anyone have Android's aquamail app successfully connecting to a
> Postfix server? If so, w hat settings did you use? I keep getting an
> authentication denied error. I've tried for authentication choose
> automatically, sasl plain, sasl login. For server security I've tried
> ssl strict check, ssl accept any (both on port 465), and starttls
> strict check and starttls accept any (port 587).
>
> Thanks.
> Dave.


Reply | Threaded
Open this post in threaded view
|

Re: aquamail connecting to postfix

Bill Cole-3
In reply to this post by David Mehler
On 11 Feb 2018, at 18:12, David Mehler wrote:

> Hello,
>
> Does anyone have Android's aquamail app successfully connecting to a
> Postfix server? If so, w hat settings did you use? I keep getting an
> authentication denied error. I've tried for authentication choose
> automatically, sasl plain, sasl login. For server security I've tried
> ssl strict check, ssl accept any (both on port 465), and starttls
> strict check and starttls accept any (port 587).

This reads as if you haven't tried simply telling Postfix to not request
client certs at all. Unless you are using X.509 certs for user
authentication, it is best to leave smtpd_tls_CAfile and
smtpd_tls_CApath at their defaults (empty) and smtpd_tls_ask_ccert at
its default (no)


And as always: if you want detailed and specific Postfix help here, you
should follow the advice in the last section of the Postfix DEBUG_README
file.
Reply | Threaded
Open this post in threaded view
|

Re: aquamail connecting to postfix

David Mehler
Hello,

My thanks to those who suggested the debug document. While that wasn't
it, the issue wasn't with postfix at all, it did get me looking at
Dovecot. Postfix does Sasl authentication using Dovecot. Dovecot gets
it's username and password from a MySQL database. The query Dovecot
was sending was wrong and it only showed up on outgoing connections,
incoming authentication worked fine.

Again my thanks.
Dave.


On 2/11/18, Bill Cole <[hidden email]> wrote:

> On 11 Feb 2018, at 18:12, David Mehler wrote:
>
>> Hello,
>>
>> Does anyone have Android's aquamail app successfully connecting to a
>> Postfix server? If so, w hat settings did you use? I keep getting an
>> authentication denied error. I've tried for authentication choose
>> automatically, sasl plain, sasl login. For server security I've tried
>> ssl strict check, ssl accept any (both on port 465), and starttls
>> strict check and starttls accept any (port 587).
>
> This reads as if you haven't tried simply telling Postfix to not request
> client certs at all. Unless you are using X.509 certs for user
> authentication, it is best to leave smtpd_tls_CAfile and
> smtpd_tls_CApath at their defaults (empty) and smtpd_tls_ask_ccert at
> its default (no)
>
>
> And as always: if you want detailed and specific Postfix help here, you
> should follow the advice in the last section of the Postfix DEBUG_README
> file.
>
Reply | Threaded
Open this post in threaded view
|

Re: aquamail connecting to postfix

John Allen
In reply to this post by David Mehler
Hi dav,

My internet was down overnight, snow plough hit encapsulation point.

These are my postfix config files, plus my dovecot stuff.

Hope it helps.

John A



On 2018-02-11 06:12 PM, David Mehler wrote:

> Hello,
>
> Does anyone have Android's aquamail app successfully connecting to a
> Postfix server? If so, w hat settings did you use? I keep getting an
> authentication denied error. I've tried for authentication choose
> automatically, sasl plain, sasl login. For server security I've tried
> ssl strict check, ssl accept any (both on port 465), and starttls
> strict check and starttls accept any (port 587).
>
> Thanks.
> Dave.


postfix.main (5K) Download Attachment
postfix.master (5K) Download Attachment
dovecot.conf (9K) Download Attachment