compile postfix 3.x from source on freebsd 11.x [patch]

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

compile postfix 3.x from source on freebsd 11.x [patch]

no@spam@mgedv.net
hi wietse & postfix-folks, thanks for the best MX out there - still!
feel free to apply this patch if reqd.

--- ./src/util/sys_defs.h.orig  2017-02-02 02:31:15.000000000 +0100
+++ ./src/util/sys_defs.h       2017-04-03 15:57:19.205806000 +0200
@@ -30,6 +30,7 @@
 #if defined(FREEBSD2) || defined(FREEBSD3) || defined(FREEBSD4) \
     || defined(FREEBSD5) || defined(FREEBSD6) || defined(FREEBSD7) \
     || defined(FREEBSD8) || defined(FREEBSD9) || defined(FREEBSD10) \
+    || defined(FREEBSD11) \
     || defined(BSDI2) || defined(BSDI3) || defined(BSDI4) \
     || defined(OPENBSD2) || defined(OPENBSD3) || defined(OPENBSD4) \
     || defined(OPENBSD5) || defined(OPENBSD6) \
--- makedefs.orig       2017-02-12 16:32:10.000000000 +0100
+++ makedefs    2017-04-03 15:56:15.710429000 +0200
@@ -284,6 +284,15 @@
                : ${SHLIB_ENV="LD_LIBRARY_PATH=`pwd`/lib"}
                : ${PLUGIN_LD="${CC} -shared"}
                ;;
+  FreeBSD.11*) SYSTYPE=FREEBSD11
+               : ${CC=cc}
+               : ${SHLIB_SUFFIX=.so}
+               : ${SHLIB_CFLAGS=-fPIC}
+               : ${SHLIB_LD="${CC} -shared"' -Wl,-soname,${LIB}'}
+               : ${SHLIB_RPATH='-Wl,-rpath,${SHLIB_DIR}'}
+               : ${SHLIB_ENV="LD_LIBRARY_PATH=`pwd`/lib"}
+               : ${PLUGIN_LD="${CC} -shared"}
+               ;;
  DragonFly.*)  SYSTYPE=DRAGONFLY
                ;;
   OpenBSD.2*)  SYSTYPE=OPENBSD2

Reply | Threaded
Open this post in threaded view
|

Re: compile postfix 3.x from source on freebsd 11.x [patch]

Wietse Venema
no@[hidden email]:
> hi wietse & postfix-folks, thanks for the best MX out there - still!
> feel free to apply this patch if reqd.

Thanks. I gather that there are no changes in the behaviof of
libraries or kernel. I'd like to download and install FreeBSD11 in
a VM, but that will have to wait until electrical power is restored.

        Wietse

> --- ./src/util/sys_defs.h.orig  2017-02-02 02:31:15.000000000 +0100
> +++ ./src/util/sys_defs.h       2017-04-03 15:57:19.205806000 +0200
> @@ -30,6 +30,7 @@
>  #if defined(FREEBSD2) || defined(FREEBSD3) || defined(FREEBSD4) \
>      || defined(FREEBSD5) || defined(FREEBSD6) || defined(FREEBSD7) \
>      || defined(FREEBSD8) || defined(FREEBSD9) || defined(FREEBSD10) \
> +    || defined(FREEBSD11) \
>      || defined(BSDI2) || defined(BSDI3) || defined(BSDI4) \
>      || defined(OPENBSD2) || defined(OPENBSD3) || defined(OPENBSD4) \
>      || defined(OPENBSD5) || defined(OPENBSD6) \
> --- makedefs.orig       2017-02-12 16:32:10.000000000 +0100
> +++ makedefs    2017-04-03 15:56:15.710429000 +0200
> @@ -284,6 +284,15 @@
>                 : ${SHLIB_ENV="LD_LIBRARY_PATH=`pwd`/lib"}
>                 : ${PLUGIN_LD="${CC} -shared"}
>                 ;;
> +  FreeBSD.11*) SYSTYPE=FREEBSD11
> +               : ${CC=cc}
> +               : ${SHLIB_SUFFIX=.so}
> +               : ${SHLIB_CFLAGS=-fPIC}
> +               : ${SHLIB_LD="${CC} -shared"' -Wl,-soname,${LIB}'}
> +               : ${SHLIB_RPATH='-Wl,-rpath,${SHLIB_DIR}'}
> +               : ${SHLIB_ENV="LD_LIBRARY_PATH=`pwd`/lib"}
> +               : ${PLUGIN_LD="${CC} -shared"}
> +               ;;
>   DragonFly.*)  SYSTYPE=DRAGONFLY
>                 ;;
>    OpenBSD.2*)  SYSTYPE=OPENBSD2
>
>
Reply | Threaded
Open this post in threaded view
|

Re: compile postfix 3.x from source on freebsd 11.x [patch]

Herbert J. Skuhra-3
In reply to this post by no@spam@mgedv.net
On Sun, 04 Mar 2018 19:06:52 +0100,
"no@[hidden email]" <[hidden email]> wrote:
>
> hi wietse & postfix-folks, thanks for the best MX out there - still!
> feel free to apply this patch if reqd.

These changes are part of the FreeBSD port for years.

<https://svnweb.freebsd.org/ports/head/mail/postfix/files/patch-src_util_sys__defs.h?view=log>
<https://svnweb.freebsd.org/ports/head/mail/postfix/files/patch-makedefs?view=log>

--
Herbert
Reply | Threaded
Open this post in threaded view
|

Re: compile postfix 3.x from source on freebsd 11.x [patch]

Postfix User-2
In reply to this post by no@spam@mgedv.net
On Sun, 4 Mar 2018 19:06:52 +0100, no@[hidden email] stated:

>hi wietse & postfix-folks, thanks for the best MX out there - still!
>feel free to apply this patch if reqd.
>
>--- ./src/util/sys_defs.h.orig  2017-02-02 02:31:15.000000000 +0100
>+++ ./src/util/sys_defs.h       2017-04-03 15:57:19.205806000 +0200
>@@ -30,6 +30,7 @@
> #if defined(FREEBSD2) || defined(FREEBSD3) || defined(FREEBSD4) \
>     || defined(FREEBSD5) || defined(FREEBSD6) || defined(FREEBSD7) \
>     || defined(FREEBSD8) || defined(FREEBSD9) || defined(FREEBSD10) \
>+    || defined(FREEBSD11) \
>     || defined(BSDI2) || defined(BSDI3) || defined(BSDI4) \
>     || defined(OPENBSD2) || defined(OPENBSD3) || defined(OPENBSD4) \
>     || defined(OPENBSD5) || defined(OPENBSD6) \
>--- makedefs.orig       2017-02-12 16:32:10.000000000 +0100
>+++ makedefs    2017-04-03 15:56:15.710429000 +0200
>@@ -284,6 +284,15 @@
>                : ${SHLIB_ENV="LD_LIBRARY_PATH=`pwd`/lib"}
>                : ${PLUGIN_LD="${CC} -shared"}
>                ;;
>+  FreeBSD.11*) SYSTYPE=FREEBSD11
>+               : ${CC=cc}
>+               : ${SHLIB_SUFFIX=.so}
>+               : ${SHLIB_CFLAGS=-fPIC}
>+               : ${SHLIB_LD="${CC} -shared"' -Wl,-soname,${LIB}'}
>+               : ${SHLIB_RPATH='-Wl,-rpath,${SHLIB_DIR}'}
>+               : ${SHLIB_ENV="LD_LIBRARY_PATH=`pwd`/lib"}
>+               : ${PLUGIN_LD="${CC} -shared"}
>+               ;;
>  DragonFly.*)  SYSTYPE=DRAGONFLY
>                ;;
>   OpenBSD.2*)  SYSTYPE=OPENBSD2
>

Maybe I am missing something; however, I have been running Postfix
3.4-(whatever) on FreeBSD-11 and above since it was released.
Reply | Threaded
Open this post in threaded view
|

Re: compile postfix 3.x from source on freebsd 11.x [patch]

Herbert J. Skuhra-3
On Sun, 04 Mar 2018 21:31:44 +0100,
Postfix User <[hidden email]> wrote:
 
> Maybe I am missing something; however, I have been running Postfix
> 3.4-(whatever) on FreeBSD-11 and above since it was released.

You either built the postfix port (which already includes these
changes) or installed a package? Otherwise you will see:

ATTENTION:
ATTENTION: Unknown system type: FreeBSD 11.1-STABLE
ATTENTION:
*** Error code 1

--
Herbert