multi instance postfix with 2 IP address and 2 sending domains

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

multi instance postfix with 2 IP address and 2 sending domains

anvartay
Hello,

I have configured server to support 2 sending IP addresses with
corresponding 2 sending domains. DKIM, SPF, reverse hostname works
correct, primary and secondary instances are setup with corresponding
myhostname and smtp_helo_name. smtp_bind_address also configured correct
on both instances. But for some reason Gmail or Microsoft Outlook
detecting second domain as spam but first one working well. How to debug
this? I can provide any details if needed.

Best regards,

--
Anvar Kuchkartaev
[hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: multi instance postfix with 2 IP address and 2 sending domains

Fabian A. Santiago
January 30, 2018 3:56 PM, "Anvar Kuchkartaev" <[hidden email]> wrote:

> Hello,
>
> I have configured server to support 2 sending IP addresses with corresponding 2 sending domains.
> DKIM, SPF, reverse hostname works correct, primary and secondary instances are setup with
> corresponding myhostname and smtp_helo_name. smtp_bind_address also configured correct on both
> instances. But for some reason Gmail or Microsoft Outlook detecting second domain as spam but first
> one working well. How to debug this? I can provide any details if needed.
>
> Best regards,
>
> -- Anvar Kuchkartaev
> [hidden email]

do your spf record(s) specify both IP's? Maybe the 2nd domain uses the wrong IP as per your SPF record?

--

Thanks,

Fabian S.

OpenPGP: 3C3FA072ACCB7AC5DB0F723455502B0EEB9070FC
Reply | Threaded
Open this post in threaded view
|

Re: multi instance postfix with 2 IP address and 2 sending domains

anvartay
currently spf record of both domains are the same:
"v=spf1 a mx ptr ptr:sendingdomain1.com ptr:sendingdomain2.com ~all"

Might PTR causing issue because of it is deprecated?


On 30/01/18 22:00, Fabian A. Santiago wrote:

> January 30, 2018 3:56 PM, "Anvar Kuchkartaev" <[hidden email]> wrote:
>
>> Hello,
>>
>> I have configured server to support 2 sending IP addresses with corresponding 2 sending domains.
>> DKIM, SPF, reverse hostname works correct, primary and secondary instances are setup with
>> corresponding myhostname and smtp_helo_name. smtp_bind_address also configured correct on both
>> instances. But for some reason Gmail or Microsoft Outlook detecting second domain as spam but first
>> one working well. How to debug this? I can provide any details if needed.
>>
>> Best regards,
>>
>> -- Anvar Kuchkartaev
>> [hidden email]
> do your spf record(s) specify both IP's? Maybe the 2nd domain uses the wrong IP as per your SPF record?
>
> --
>
> Thanks,
>
> Fabian S.
>
> OpenPGP: 3C3FA072ACCB7AC5DB0F723455502B0EEB9070FC

--
Anvar Kuchkartaev
[hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: multi instance postfix with 2 IP address and 2 sending domains

Fabian A. Santiago
January 30, 2018 4:08 PM, "Anvar Kuchkartaev" <[hidden email]> wrote:

> currently spf record of both domains are the same:
> "v=spf1 a mx ptr ptr:sendingdomain1.com ptr:sendingdomain2.com ~all"
>
> Might PTR causing issue because of it is deprecated?
>
> On 30/01/18 22:00, Fabian A. Santiago wrote:
>
>> January 30, 2018 3:56 PM, "Anvar Kuchkartaev" <[hidden email]> wrote:
>>
>>> Hello,
>>>
>>> I have configured server to support 2 sending IP addresses with corresponding 2 sending domains.
>>> DKIM, SPF, reverse hostname works correct, primary and secondary instances are setup with
>>> corresponding myhostname and smtp_helo_name. smtp_bind_address also configured correct on both
>>> instances. But for some reason Gmail or Microsoft Outlook detecting second domain as spam but first
>>> one working well. How to debug this? I can provide any details if needed.
>>>
>>> Best regards,
>>>
>>> -- Anvar Kuchkartaev
>>> [hidden email]
>>
>> do your spf record(s) specify both IP's? Maybe the 2nd domain uses the wrong IP as per your SPF
>> record?
>>
>> --
>>
>> Thanks,
>>
>> Fabian S.
>>
>> OpenPGP: 3C3FA072ACCB7AC5DB0F723455502B0EEB9070FC
>
> -- Anvar Kuchkartaev
> [hidden email]

not sure..hmmm. mine is structured as "mx a ... -all", with the IP addresses associated with my email server in CIDR format. but you do what is right for your domains. i've read that ptr records are used when more than one MX server (such as in a cluster) represent a domain's valid sending server(s).

--

Thanks,

Fabian S.

OpenPGP: 3C3FA072ACCB7AC5DB0F723455502B0EEB9070FC
Reply | Threaded
Open this post in threaded view
|

Re: multi instance postfix with 2 IP address and 2 sending domains

anvartay
I just have modified SPF record to a mx ip4:... ~all and included all IP
addresses of the server. Since TTL was 5 seconds propogation took not
too long but without luck.

Server has 4 IP addresses and customer requested to have send only mail
server on 3rd and 4th addresses of their OpenVZ server. Postfix
configured on 3rd address as primary instance with "/etc/postfix"
configs working well.

I used:
http://www.linuxpcfix.com/configure-postfix-with-multiple-instances-on-centos/

as tutorial for multi instance postfix. What other options could causing
issue?


On 30/01/18 22:32, Fabian A. Santiago wrote:

> January 30, 2018 4:08 PM, "Anvar Kuchkartaev" <[hidden email]> wrote:
>
>> currently spf record of both domains are the same:
>> "v=spf1 a mx ptr ptr:sendingdomain1.com ptr:sendingdomain2.com ~all"
>>
>> Might PTR causing issue because of it is deprecated?
>>
>> On 30/01/18 22:00, Fabian A. Santiago wrote:
>>
>>> January 30, 2018 3:56 PM, "Anvar Kuchkartaev" <[hidden email]> wrote:
>>>
>>>> Hello,
>>>>
>>>> I have configured server to support 2 sending IP addresses with corresponding 2 sending domains.
>>>> DKIM, SPF, reverse hostname works correct, primary and secondary instances are setup with
>>>> corresponding myhostname and smtp_helo_name. smtp_bind_address also configured correct on both
>>>> instances. But for some reason Gmail or Microsoft Outlook detecting second domain as spam but first
>>>> one working well. How to debug this? I can provide any details if needed.
>>>>
>>>> Best regards,
>>>>
>>>> -- Anvar Kuchkartaev
>>>> [hidden email]
>>> do your spf record(s) specify both IP's? Maybe the 2nd domain uses the wrong IP as per your SPF
>>> record?
>>>
>>> --
>>>
>>> Thanks,
>>>
>>> Fabian S.
>>>
>>> OpenPGP: 3C3FA072ACCB7AC5DB0F723455502B0EEB9070FC
>> -- Anvar Kuchkartaev
>> [hidden email]
> not sure..hmmm. mine is structured as "mx a ... -all", with the IP addresses associated with my email server in CIDR format. but you do what is right for your domains. i've read that ptr records are used when more than one MX server (such as in a cluster) represent a domain's valid sending server(s).
>
> --
>
> Thanks,
>
> Fabian S.
>
> OpenPGP: 3C3FA072ACCB7AC5DB0F723455502B0EEB9070FC

--
Anvar Kuchkartaev
[hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: multi instance postfix with 2 IP address and 2 sending domains

Marat Khalili
On 31/01/18 00:38, Anvar Kuchkartaev wrote:
> Since TTL was 5 seconds propogation took not too long but without luck.
Many DNS servers silently increase TTL if it's so small. Wait at least
an hour to be sure.

> Might PTR causing issue because of it is deprecated?
Are you sure you cannot use "a" or "ip4"/"ip6" mechanisms instead?

--

With Best Regards,
Marat Khalili