myorigin will not be honored

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

myorigin will not be honored

Johannes Black
Hi,

I am using Debian 10 and I am bulding a server with a mail.someurl.com
hostname and an MX entry for someurl.com.

I have setup

myorigin = /etc/mailname

and /etc/mailname has

someurl.com

as an entry.

If I test it with

echo "test"| mail [hidden email]

(mail comes from the mailutils package)

I unfortunately still get the [hidden email] source address.
The same result happens if I use mutt. I reloaded the configuration with
'postfix reload' before.

Any idea why myorigin is not working? Did I miss a configuration?

Greetings and thanks,
Johannes

Reply | Threaded
Open this post in threaded view
|

Re: myorigin will not be honored

Wietse Venema
Johannes Black:

> Hi,
>
> I am using Debian 10 and I am bulding a server with a mail.someurl.com
> hostname and an MX entry for someurl.com.
>
> I have setup
>
> myorigin = /etc/mailname
>
> and /etc/mailname has
>
> someurl.com
>
> as an entry.
>
> If I test it with
>
> echo "test"| mail [hidden email]
>
> (mail comes from the mailutils package)
>
> I unfortunately still get the [hidden email] source address.
> The same result happens if I use mutt. I reloaded the configuration with
> 'postfix reload' before.
>
> Any idea why myorigin is not working? Did I miss a configuration?

myorigin is ussed only if an email address does not already have a
domain name. If the mail submission program already appends a
domain then myorigin will not be used.

        Wietse
Reply | Threaded
Open this post in threaded view
|

Re: myorigin will not be honored

Johannes Black
Okay thanks, I will investigate further.

On 29.11.2020 18:11, Wietse Venema wrote:

> Johannes Black:
>> Hi,
>>
>> I am using Debian 10 and I am bulding a server with a mail.someurl.com
>> hostname and an MX entry for someurl.com.
>>
>> I have setup
>>
>> myorigin = /etc/mailname
>>
>> and /etc/mailname has
>>
>> someurl.com
>>
>> as an entry.
>>
>> If I test it with
>>
>> echo "test"| mail [hidden email]
>>
>> (mail comes from the mailutils package)
>>
>> I unfortunately still get the [hidden email] source address.
>> The same result happens if I use mutt. I reloaded the configuration with
>> 'postfix reload' before.
>>
>> Any idea why myorigin is not working? Did I miss a configuration?
>
> myorigin is ussed only if an email address does not already have a
> domain name. If the mail submission program already appends a
> domain then myorigin will not be used.
>
> Wietse
>