not adding message-id

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

not adding message-id

postfix alain
Hello,

I have a issue with a message-id automatically added when not present.

Postfix mail system:
postfix 25 (content-filter) --> AV  10026 --> postfix 10025

Summary of the problem:
When a message arrives to the postfix mail system, if it not present, a message-id is added by the second postfix MTA (10025) while "always_add_missing_headers" is set to "no".
Note that this second MTA listens to the loopback interface (see master.cf below).

Logs:
Jun  5 16:51:37 rhel62-agu-fe1 postfix/smtpd[3063]: C51FD40092: client=unknown[10.1.6.31]
Jun  5 16:51:46 rhel62-agu-fe1 postfix/cleanup[3067]: C51FD40092: message-id=<>
Jun  5 16:51:46 rhel62-agu-fe1 postfix/qmgr[2960]: C51FD40092: from=<[hidden email]>, size=215, nrcpt=1 (queue active)
Jun  5 16:51:57 rhel62-agu-fe1 postfix/smtp[3068]: C51FD40092: to=<[hidden email]>, relay=127.0.0.1[127.0.0.1]:10025, delay=26, delays=14/0.01/0/11, dsn=2.0.0, status=sent (250 OK, sent 5B16A382_25736_9)


[root@rhel62-agu-fe1 maillog]# zgrep 98BED400A0 20180605_maillog.log.gz
Jun  5 16:51:57 rhel62-agu-fe1 postfix/smtpd[3070]: 98BED400A0: client=localhost[127.0.0.1]
Jun  5 16:51:57 rhel62-agu-fe1 postfix/cleanup[3067]: 98BED400A0: message-id=<[hidden email]>
Jun  5 16:51:57 rhel62-agu-fe1 postfix/qmgr[2960]: 98BED400A0: from=<[hidden email]>, size=608, nrcpt=1 (queue active)
Jun  5 16:51:57 rhel62-agu-fe1 postfix/smtp[3071]: 98BED400A0: to=<[hidden email]>, relay=10.1.6.25[10.1.6.25]:25, delay=0.11, delays=0.05/0.01/0.03/0.03, dsn=2.0.0, status=sent (250 2.0.0 Ok: queued as BB9841411AC)


Default configuration (25):
mail_version = 2.7.3
always_add_missing_headers = no
local_header_rewrite_clients = permit_inet_interfaces
inet_interfaces = all

master.cf (for 0026 configuration):
127.0.0.1:10026  inet   n       -       y       -       -       smtpd
        -o content_filter=
        -o myhostname=localhost.$mydomain
        -o local_recipient_maps=
        -o relay_recipient_maps=
        -o smtpd_restriction_classes=
        -o smtpd_client_restrictions=
        -o smtpd_helo_restrictions=
        -o smtpd_sender_restrictions=
        -o smtpd_recipient_restrictions=permit_mynetworks,reject
        -o smtpd_milters=
        -o strict_rfc821_envelopes=no
        -o mynetworks=127.0.0.0/8
        -o smtpd_tls_security_level=none
        -o smtpd_timeout=$smtpfilter_timeout


Thank you for your support.
Alain





Reply | Threaded
Open this post in threaded view
|

Re: not adding message-id

Markus Schönhaber-16
Postfix Alain, 07.06.2018 11:33 +0200:

> I have a issue with a message-id automatically added when not present.

> mail_version = 2.7.3
> always_add_missing_headers = no
  ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
That's probably why.
http://www.postfix.org/postconf.5.html#always_add_missing_headers

--
Regards
  mks
Reply | Threaded
Open this post in threaded view
|

Re: not adding message-id

Wietse Venema
In reply to this post by postfix alain
postfix alain:
> Hello,
>
> I have a issue with a message-id automatically added when not present.
>
>  Postfix mail system:
> postfix 25 (content-filter) --> AV 10026 --> postfix 10025
>
> Summary of the problem:
> When a message arrives to the postfix mail system, if it not present, a message-id is added by the second postfix MTA (10025) while "always_add_missing_headers" is set to "no".

Postfix will add headers for local submssion (whitelisted
by default by "local_header_rewrite_clients = permit_inet_interfaces")

> local_header_rewrite_clients = permit_inet_interfaces

That's OK for main.cf, but you have to disable that on the post-filter
smtpd service.

        Wietse