[postfix-jp: 4411] "max_use=1" が効かない事象

Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

[postfix-jp: 4411] "max_use=1" が効かない事象

kawakami
初めまして。川上と申します。

master.cf内で"max_use=1"を設定しているのにも関わらず、
smtpdプロセスがdisconnectした後にも終了せず、同じプロセスIDで
別のメールを処理する事象がありました。

事象は以下の状況で発生しました。

1 IPv4でメールが送信され、正常に転送処理が終了
2 IPv4でメールが送信され、451エラーでstatus=defferredとなり処理が終了
3 IPv6でメールが送信され、451エラーでstatus=defferredとなり処理が終了

上記の内、2と3の処理でpostfix/smtpdのプロセスIDが同じとなっていました。

同じように、max_useの設定が効かない事象に遭遇された方はいらっしゃいますでしょうか?
何かご存知の方がいらっしゃいましたら情報をいただけますと幸いです。

_______________________________________________
Postfix-jp-list mailing list
[hidden email]
https://lists.osdn.me/mailman/listinfo/postfix-jp-list
Reply | Threaded
Open this post in threaded view
|

[postfix-jp: 4412] Re: "max_use=1" が効かない事象

Hiroshi Takahashi
高橋@船橋です。

http://www.postfix.org/postconf.5.html
---------------------------
max_use (default: 100)
The maximal number of incoming connections that a Postfix daemon
process will service before terminating voluntarily. This parameter
is ignored by the Postfix queue manager and by other long-lived
Postfix daemon processes.

と書いてあるので、その動作は正常のような気がします。
※外してたら、ごめんなさい。

On 2020/08/31 13:03, kawakami wrote:

> 初めまして。川上と申します。
>
> master.cf内で"max_use=1"を設定しているのにも関わらず、
> smtpdプロセスがdisconnectした後にも終了せず、同じプロセスIDで
> 別のメールを処理する事象がありました。
>
> 事象は以下の状況で発生しました。
>
> 1 IPv4でメールが送信され、正常に転送処理が終了
> 2 IPv4でメールが送信され、451エラーでstatus=defferredとなり処理が終了
> 3 IPv6でメールが送信され、451エラーでstatus=defferredとなり処理が終了
>
> 上記の内、2と3の処理でpostfix/smtpdのプロセスIDが同じとなっていました。
>
> 同じように、max_useの設定が効かない事象に遭遇された方はいらっしゃい
> ますでしょうか?
> 何かご存知の方がいらっしゃいましたら情報をいただけますと幸いです。
>
> _______________________________________________
> Postfix-jp-list mailing list
> [hidden email]
> https://lists.osdn.me/mailman/listinfo/postfix-jp-list

--
Hiroshi Takahashi
Funabashi Chiba, Japan
http://ameblo.jp/it-tutor/
http://twitter.com/flash_takahashi

_______________________________________________
Postfix-jp-list mailing list
[hidden email]
https://lists.osdn.me/mailman/listinfo/postfix-jp-list
Reply | Threaded
Open this post in threaded view
|

[postfix-jp: 4413] Re: "max_use=1" が効かない事象

kawakami
川上です。

ご返信ありがとうございます。

無視されるとありますが、どのような条件なのかが
よく分からないのです。

事象が発生している状況を細かく言葉で説明しますと、

・IPv4で送信されたメールが457エラーとなった場合、
 次のIPv6で送信されたメールが同じsmtpdプロセスで処理され、
 同様に457エラーとなってしまうことがある
・上記の条件でも、発生する頻度は半分以下

です。
※後出し部分もあり申し訳ございません。

同じプロトコルの別メール同士で同じプロセスIDになることはありません。

なんとなくIPv4とIPv6とでプロセス処理の判定に誤りが
あるような動きに見えます。
ソースコードを読む前に、手掛かりを探っているところです。


On 2020/08/31 16:35, Hiroshi Takahashi wrote:

> 高橋@船橋です。
>
> http://www.postfix.org/postconf.5.html
> ---------------------------
> max_use (default: 100)
> The maximal number of incoming connections that a Postfix daemon
> process will service before terminating voluntarily. This parameter
> is ignored by the Postfix queue manager and by other long-lived
> Postfix daemon processes.
>
> と書いてあるので、その動作は正常のような気がします。
> ※外してたら、ごめんなさい。
>
> On 2020/08/31 13:03, kawakami wrote:
>> 初めまして。川上と申します。
>>
>> master.cf内で"max_use=1"を設定しているのにも関わらず、
>> smtpdプロセスがdisconnectした後にも終了せず、同じプロセスIDで
>> 別のメールを処理する事象がありました。
>>
>> 事象は以下の状況で発生しました。
>>
>> 1 IPv4でメールが送信され、正常に転送処理が終了
>> 2 IPv4でメールが送信され、451エラーでstatus=defferredとなり処理が終了
>> 3 IPv6でメールが送信され、451エラーでstatus=defferredとなり処理が終了
>>
>> 上記の内、2と3の処理でpostfix/smtpdのプロセスIDが同じとなっていました。
>>
>> 同じように、max_useの設定が効かない事象に遭遇された方はいらっしゃい
>> ますでしょうか?
>> 何かご存知の方がいらっしゃいましたら情報をいただけますと幸いです。
>>
>> _______________________________________________
>> Postfix-jp-list mailing list
>> [hidden email]
>> https://lists.osdn.me/mailman/listinfo/postfix-jp-list
>

_______________________________________________
Postfix-jp-list mailing list
[hidden email]
https://lists.osdn.me/mailman/listinfo/postfix-jp-list