[postfix-users] greeted me with my own hostname mail.site

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

[postfix-users] greeted me with my own hostname mail.site

Mitzel,Karlheinz

Hallo zusammen,

 

ich habe einen neuen Postfix auf SuSE 12.2 aufgesetzt, der als Relay-Server für Exchange arbeiten soll.

Der Postfix-Server steht in einer DMZ und soll Mails die von außen kommen, an Exchange im internen Netz weiterleiten.

Mail aus dem internen Netz werden an Postfix geleitet und dann nach extern zugestellt.

 

Mails von intern nach extern werden normal zugestellt. Mails von extern nach intern werden Rejected.

 

Folgende auffälligkeiten (fett markiert) werden im Mail-Log aufgezeichnet:

 

Feb 23 13:22:49 mail postfix/cleanup[13023]: EE3AA2C443A: message-id=<trinity-f53b3f71-0267-4e0a-a982-63921fda94d7-1361622167031@3capp-webde-bs03>

Feb 23 13:22:49 mail postfix/qmgr[12363]: EE3AA2C443A: from=<[hidden email]>, size=2917, nrcpt=1 (queue active)

Feb 23 13:22:49 mail postfix/smtpd[13019]: disconnect from mout.web.de[212.227.15.3]

Feb 23 13:22:52 mail postfix/smtpd[13027]: connect from localhost[127.0.0.1]

Feb 23 13:22:52 mail postfix/smtpd[13027]: 99AFF2C4481: client=localhost[127.0.0.1]

Feb 23 13:22:52 mail postfix/cleanup[13023]: 99AFF2C4481: message-id=<trinity-f53b3f71-0267-4e0a-a982-63921fda94d7-1361622167031@3capp-webde-bs03>

Feb 23 13:22:52 mail postfix/qmgr[12363]: 99AFF2C4481: from=<[hidden email]>, size=3346, nrcpt=1 (queue active)

Feb 23 13:22:52 mail postfix/smtpd[13027]: disconnect from localhost[127.0.0.1]

Feb 23 13:22:52 mail amavis[1695]: (01695-13) Passed CLEAN {RelayedOpenRelay}, [212.227.15.3]:61646 [80.153.146.42] <[hidden email]> -> <[hidden email]>, Queue-ID: EE3AA2C443A, Message-ID: <trinity-f53b3f71-0267-4e0a-a982-63921fda94d7-1361622167031@3capp-webde-bs03>, mail_id: sCxJxNVL1yHu, Hits: 1.097, size: 2916, queued_as: 99AFF2C4481, 3623 ms

Feb 23 13:22:52 mail postfix/smtp[13024]: EE3AA2C443A: to=<[hidden email]>, relay=127.0.0.1[127.0.0.1]:10024, delay=3.8, delays=0.16/0.01/0.01/3.6, dsn=2.0.0, status=sent (250 2.0.0 from MTA(smtp:[127.0.0.1]:10025): 250 2.0.0 Ok: queued as 99AFF2C4481)

Feb 23 13:22:52 mail postfix/qmgr[12363]: EE3AA2C443A: removed

Feb 23 13:22:52 mail postfix/smtpd[13019]: connect from unknown[192.168.2.1]

Feb 23 13:22:52 mail postfix/smtp[13028]: warning: host service.stb-mitzel.de[80.153.146.42]:25 greeted me with my own hostname mail.site

Feb 23 13:22:52 mail postfix/smtp[13028]: warning: host service.stb-mitzel.de[80.153.146.42]:25 replied to HELO/EHLO with my own hostname mail.site

 

Bei meinem zur Zeit noch aktiven Postfix tritt dieses Problem nicht auf.

Auf dem neuen Server wurde lediglich noch AMAVISnew mit ClamAV eingebunden.

 

Nachfolgend die Einstellungen der main.cf:

 

alias_maps = hash:/etc/aliases

biff = no

canonical_maps = hash:/etc/postfix/canonical

command_directory = /usr/sbin

config_directory = /etc/postfix

content_filter = amavis:[127.0.0.1]:10024

daemon_directory = /usr/lib/postfix

data_directory = /var/lib/postfix

debug_peer_level = 2

defer_transports =

delay_warning_time = 1h

disable_dns_lookups = no

disable_mime_output_conversion = no

html_directory = /usr/share/doc/packages/postfix-doc/html

inet_interfaces = all

inet_protocols = all

mail_owner = postfix

mail_spool_directory = /var/mail

mailbox_command =

mailbox_size_limit = 0

mailbox_transport =

mailq_path = /usr/bin/mailq

manpage_directory = /usr/share/man

masquerade_classes = envelope_sender, header_sender, header_recipient

masquerade_domains =

masquerade_exceptions = root

message_size_limit = 10240000

mydestination = $myhostname, localhost.$mydomain

myhostname = mail.site

mynetworks = 127.0.0.0/8 192.168.2.0/24 192.168.10.0/24

mynetworks_style = subnet

newaliases_path = /usr/bin/newaliases

queue_directory = /var/spool/postfix

readme_directory = /usr/share/doc/packages/postfix-doc/README_FILES

relay_domains = hash:/etc/postfix/relay_domains

relay_recipient_maps = hash:/etc/postfix/relay_recipients

relayhost =

relocated_maps = hash:/etc/postfix/relocated

sample_directory = /usr/share/doc/packages/postfix-doc/samples

sender_canonical_maps = hash:/etc/postfix/sender_canonical

sendmail_path = /usr/sbin/sendmail

setgid_group = maildrop

smtp_sasl_auth_enable = no

smtp_sasl_password_maps =

smtp_sasl_security_options =

smtp_use_tls = no

smtpd_client_restrictions =

smtpd_helo_required = no

smtpd_helo_restrictions =

smtpd_recipient_restrictions = permit_mynetworks, reject_unauth_destination

smtpd_sasl_auth_enable = no

smtpd_sender_restrictions = hash:/etc/postfix/access

smtpd_use_tls = no

strict_8bitmime = no

strict_rfc821_envelopes = no

transport_maps = hash:/etc/postfix/transport

unknown_local_recipient_reject_code = 550

 

Ich würde mich freuen, wenn jemand einen Lösungsvorschlag hätte. Ich komme da im Moment nicht weiter.

Es kann eigentlich nur eine Kleinigkeit falsch sein. Mit meinem alten Postfix, hat es mit fast identischer Konfiguration immerhin

Jahrelang funktioniert und tut es immer noch.

 

Wenn noch weitere Informationen nötig sein sollten, bitte eine Mail schreiben.

 

Gruß

 

Karlheinz

 

 


_______________________________________________
postfix-users mailing list
[hidden email]
http://de.postfix.org/cgi-bin/mailman/listinfo/postfix-users
Reply | Threaded
Open this post in threaded view
|

Re: [postfix-users] greeted me with my own hostname mail.site

Robert Schetterer-2
Am 23.02.2013 16:05, schrieb Mitzel,Karlheinz:

> Feb 23 13:22:52 mail postfix/smtp[13024]: EE3AA2C443A:
> to=<[hidden email]>, relay=127.0.0.1[127.0.0.1]:10024,
> delay=3.8, delays=0.16/0.01/0.01/3.6, dsn=2.0.0, status=sent (250 2.0.0
> from MTA(smtp:[127.0.0.1]:10025): 250 2.0.0 Ok: queued as 99AFF2C4481)
>
> Feb 23 13:22:52 mail postfix/qmgr[12363]: EE3AA2C443A: removed
>
> Feb 23 13:22:52 mail postfix/smtpd[13019]: connect from unknown[192.168.2.1]
>
> Feb 23 13:22:52 mail postfix/smtp[13028]: warning: host
> service.stb-mitzel.de[80.153.146.42]:25 *greeted* *me with my own
> hostname mail.site*
>
> Feb 23 13:22:52 mail postfix/smtp[13028]: warning: host
> service.stb-mitzel.de[80.153.146.42]:25 *replied to HELO/EHLO with my
> own hostname mail.site*
>

nur kurz, weil in Eile, im schnellen Ueberflug

die warning von postfix ist unschoen, aber wahrscheinlich nicht das Problem

mail.site als hostname ist auch nicht der renner, wenn der postfix das
relay nach aussen ist sollte der schon einen gueltigen dns namen haben usw

also wenn ich das richtig sehe
uebergibts du an amavis , und der rest fehlt im log
was macht amavis mit der mail , gehts ohne amavis ?

schaetze ich hab was uebersehen, auf jeden Fall hast du noch zu tun,
evtl werden dir noch andere antoworten

Best Regards
MfG Robert Schetterer

--
[*] sys4 AG

http://sys4.de, +49 (89) 30 90 46 64
Franziskanerstraße 15, 81669 München

Sitz der Gesellschaft: München, Amtsgericht München: HRB 199263
Vorstand: Patrick Ben Koetter, Axel von der Ohe, Marc Schiffbauer
Aufsichtsratsvorsitzender: Joerg Heidrich
_______________________________________________
postfix-users mailing list
[hidden email]
http://de.postfix.org/cgi-bin/mailman/listinfo/postfix-users
Reply | Threaded
Open this post in threaded view
|

[postfix-users] WG: greeted me with my own hostname mail.site

Mitzel,Karlheinz
In reply to this post by Mitzel,Karlheinz


-----Ursprüngliche Nachricht-----
Von: Robert Schetterer [mailto:[hidden email]]
Gesendet: Samstag, 23. Februar 2013 19:52
An: Mitzel,Karlheinz
Betreff: Re: [postfix-users] greeted me with my own hostname mail.site

Am 23.02.2013 18:31, schrieb Mitzel,Karlheinz:

> Hier mal die Abfrage nach MX-Record:
>
> C:\Users\mitzelk.STB-MITZEL>nslookup
> Standardserver:  dcsrv.stb-mitzel.local
> Address:  192.168.10.10
>
>> set type=MX
>> stb-mitzel.de
> Server:  dcsrv.stb-mitzel.local
> Address:  192.168.10.10
>
> Nicht autorisierende Antwort:
> stb-mitzel.de   MX preference = 10, mail exchanger = service.stb-mitzel.de
>
> service.stb-mitzel.de   internet address = 80.153.146.42
>>
>
> Das sollte nicht das Problem sein. Die statische IP von außen ist 80.153.146.42.
> Der DNS-Eintrag auf einem Telekom-DNS-Server ist
> "service.stb-mitzel.de Die Mail-Domain ist "stb-mitzel.de" und der MX-Record zeigt auf "service.stb-mitzel.de"
> Wie zuvor schon erwähnt funktioniert das mit einem anderen Postfix schon jahrelang.
> Und dessen lokaler Hostname und Domain lauten ebenfalls ganz anders.
>
> Die Domain an die ausgeliefert werden soll "stb-mitzel.de"
> ist in "relay_domains = hash:/etc/postfix/relay_domains" hinterlegt.
> In relay_recipient_maps sind auch die erlaubten Empfänger hinterlegt.
>
> Postfix muß sich meiner Meinung nach an einer anderen Stelle verschlucken. Aber wo ;-) ?

sorry benutze mal dig und nicht nslookup , das ist ja gauenhaft

root@log:~# dig -t mx stb-mitzel.de

; <<>> DiG 9.7.0-P1 <<>> -t mx stb-mitzel.de ;; global options: +cmd ;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 34075 ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 2, ADDITIONAL: 3

;; QUESTION SECTION:
;stb-mitzel.de.                 IN      MX

;; ANSWER SECTION:
stb-mitzel.de.          86400   IN      MX      10 service.stb-mitzel.de.

;; AUTHORITY SECTION:
stb-mitzel.de.          86400   IN      NS      ns2.webpage.t-com.de.
stb-mitzel.de.          86400   IN      NS      ns1.webpage.t-com.de.

;; ADDITIONAL SECTION:
service.stb-mitzel.de.  86400   IN      A       80.153.146.42



ich sagte doch schon , gugg in deinen amavis.log  deaktiviere amavis testweise mal, erstmal sehen dass es ohne amavis laeuft

die weiterleitung an einen internen exchange macht man mit einem smtp transport , was steht denn da drinn ?

muesste sowas sein

stb-mitzel.de smtp:[192.168.10.10]

der myhostname waere dann natuerlich auch service.stb-mitzel.de und nicht blabla.site

ausserdem mach mal vom
postfix aus telnet 192.168.10.10 25
ob du den exchange auch wirklich erreichst

wenn das nicht geht
schau mal nach

inet_interfaces =
und in der firewall wegen blocking


und wenn du kein ipv6 machst

inet_protocols = ipv4

in die main.cf

ausserdem  checken

mynetworks =  127.0.0.0/8, 192.168.10.10

steht etc, ich wuerde zwar sasl vorschlagen, aber fuers testen ist das erstmal egal

du hattest doch irgendwas geschrieben dass ein altes relay noch in Betrieb ist , die duerfen sich nicht in quere kommen

in relay_domains muss stb-mitzel.de
enthalten sein
ich wuerde zusaetzlich auch noch ein
relay_recipients machen , und oder ein recipient_verify ueber smtp


und bitte kein top posting mehr , und mails an die liste, nicht direkt an mich, so koennen dir auch andere helfen

>
> Gruß
>
> Karlheinz
>
>
> -----Ursprüngliche Nachricht-----
> Von: postfix-users
> [mailto:postfix-users-bounces+karlheinz.mitzel=[hidden email]
> x.org] Im Auftrag von Robert Schetterer
> Gesendet: Samstag, 23. Februar 2013 17:50
> An: [hidden email]
> Betreff: Re: [postfix-users] greeted me with my own hostname mail.site
>
> Am 23.02.2013 16:05, schrieb Mitzel,Karlheinz:
>> Feb 23 13:22:52 mail postfix/smtp[13024]: EE3AA2C443A:
>> to=<[hidden email]>,
>> relay=127.0.0.1[127.0.0.1]:10024, delay=3.8,
>> delays=0.16/0.01/0.01/3.6, dsn=2.0.0, status=sent (250 2.0.0 from
>> MTA(smtp:[127.0.0.1]:10025): 250 2.0.0 Ok: queued as
>> 99AFF2C4481)
>>
>> Feb 23 13:22:52 mail postfix/qmgr[12363]: EE3AA2C443A: removed
>>
>> Feb 23 13:22:52 mail postfix/smtpd[13019]: connect from
>> unknown[192.168.2.1]
>>
>> Feb 23 13:22:52 mail postfix/smtp[13028]: warning: host
>> service.stb-mitzel.de[80.153.146.42]:25 *greeted* *me with my own
>> hostname mail.site*
>>
>> Feb 23 13:22:52 mail postfix/smtp[13028]: warning: host
>> service.stb-mitzel.de[80.153.146.42]:25 *replied to HELO/EHLO with my
>> own hostname mail.site*
>>
>
> nur kurz, weil in Eile, im schnellen Ueberflug
>
> die warning von postfix ist unschoen, aber wahrscheinlich nicht das
> Problem
>
> mail.site als hostname ist auch nicht der renner, wenn der postfix das
> relay nach aussen ist sollte der schon einen gueltigen dns namen haben
> usw
>
> also wenn ich das richtig sehe
> uebergibts du an amavis , und der rest fehlt im log was macht amavis mit der mail , gehts ohne amavis ?
>
> schaetze ich hab was uebersehen, auf jeden Fall hast du noch zu tun,
> evtl werden dir noch andere antoworten
>
> Best Regards
> MfG Robert Schetterer
>
> --
> [*] sys4 AG
>
> http://sys4.de, +49 (89) 30 90 46 64
> Franziskanerstraße 15, 81669 München
>
> Sitz der Gesellschaft: München, Amtsgericht München: HRB 199263
> Vorstand: Patrick Ben Koetter, Axel von der Ohe, Marc Schiffbauer
> Aufsichtsratsvorsitzender: Joerg Heidrich
> _______________________________________________
> postfix-users mailing list
> [hidden email]
> http://de.postfix.org/cgi-bin/mailman/listinfo/postfix-users
>



Best Regards
MfG Robert Schetterer

--
[*] sys4 AG

http://sys4.de, +49 (89) 30 90 46 64
Franziskanerstraße 15, 81669 München

Sitz der Gesellschaft: München, Amtsgericht München: HRB 199263
Vorstand: Patrick Ben Koetter, Axel von der Ohe, Marc Schiffbauer
Aufsichtsratsvorsitzender: Joerg Heidrich




Ich bedanke mich für die promte Hilfestellung bei meinem Problem

Wie du empfohlen hattest, habe ich den Hostname in der main.cf angepasst,

außerdem hatte ich vergessen die Transport-Tabelle einzurichten.

Das war dann auch das Problem für die Fehlermeldung "loops back to myself"

und das "greeted me with my own hostname"

Nachdem das geändert war, haben Senden sowie Emfang und Weiterleitung

an Exchange funktioniert.


Mit den besten Grüssen an die Liste


Karlheinz










_______________________________________________
postfix-users mailing list
[hidden email]
http://de.postfix.org/cgi-bin/mailman/listinfo/postfix-users