problem with content filter and forwarded address

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

problem with content filter and forwarded address

nik600 hotmail
Hi to all.

I'm using postfix-2.5.1 with mysql

i've noticed that when a mailbox has a forward address if is set a
content filter in master.cf (for Example:)

smtp      inet  n       -       n       -       -       smtpd
        -o content_filter=filter:dummy
9009      inet  n       -       n       -       -       smtpd
        -o content_filter=filter:dummy
filter    unix  -       n       n       -       20      pipe
 flags=Rq user=filter
argv=/var/programmi/script/filtra_spamc_1.2.debug -f ${sender} --
${recipient}

The script /var/programmi/script/filtra_spamc_1.2.debug is not
executed when a mail is sent to a mailbox that is both a mailbox and
an alias.

Is that correct?
Thanks

--
/*************/
nik600
https://sourceforge.net/projects/ccmanager
https://sourceforge.net/projects/reportmaker
https://sourceforge.net/projects/nikstresser
Reply | Threaded
Open this post in threaded view
|

Re: problem with content filter and forwarded address

mouss-2
nik600 wrote:

> Hi to all.
>
> I'm using postfix-2.5.1 with mysql
>
> i've noticed that when a mailbox has a forward address if is set a
> content filter in master.cf (for Example:)
>
> smtp      inet  n       -       n       -       -       smtpd
>         -o content_filter=filter:dummy
> 9009      inet  n       -       n       -       -       smtpd
>         -o content_filter=filter:dummy
> filter    unix  -       n       n       -       20      pipe
>  flags=Rq user=filter
> argv=/var/programmi/script/filtra_spamc_1.2.debug -f ${sender} --
> ${recipient}
>
> The script /var/programmi/script/filtra_spamc_1.2.debug is not
> executed when a mail is sent to a mailbox that is both a mailbox and
> an alias.
>
> Is that correct?

No.
Reply | Threaded
Open this post in threaded view
|

Re: problem with content filter and forwarded address

nik600 hotmail
On Thu, Jun 26, 2008 at 8:13 PM, mouss <[hidden email]> wrote:

>>
>> The script /var/programmi/script/filtra_spamc_1.2.debug is not
>> executed when a mail is sent to a mailbox that is both a mailbox and
>> an alias.
>>
>> Is that correct?
>
> No.
>

Hi
thanks for your reply.
Can you suggest me how to debug this problem?

thanks



--
/*************/
nik600
https://sourceforge.net/projects/ccmanager
https://sourceforge.net/projects/reportmaker
https://sourceforge.net/projects/nikstresser
Reply | Threaded
Open this post in threaded view
|

Re: problem with content filter and forwarded address

mouss-2
nik600 wrote:

> On Thu, Jun 26, 2008 at 8:13 PM, mouss <[hidden email]> wrote:
>
>  
>>> The script /var/programmi/script/filtra_spamc_1.2.debug is not
>>> executed when a mail is sent to a mailbox that is both a mailbox and
>>> an alias.
>>>
>>> Is that correct?
>>>      
>> No.
>>
>>    
>
> Hi
> thanks for your reply.
> Can you suggest me how to debug this problem?
>  


The first step is to validate your observation:
- send a mail via smtp (not with sendmail)
- check postfix logs and see if it is not delivered to your script

if you think it does not, then show these logs (all log lines for the
test mail, from the moment postfix gets it until it gets rid of).

note that if you use -o content_filter under smtpd services, then this
won't apply to mail submitted with the sendmail command (which uses the
pickup service, not smtpd).

Also, if you have a FILTER action in one of your smtpd restrictions or
in your header/body checks, then that will override your content_filter.