"plötzlich" meldungen das mail.xx.yy:143 ungültiges zertifikat hat

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

"plötzlich" meldungen das mail.xx.yy:143 ungültiges zertifikat hat

robert rottermann-2
Hoi zäme,


ich bekomme seit einigen Tagen massenhaft  Meldungen, mein (letsencrypt)
Zertifikat auf mail.xx.yy:143 sei abgelaufen.

Wenn ich jedoch auf den Server gehe, und mit certbot renew zu erneuern
versuche, bekomme ich eine Meldung, das Zertifikat sei noch nicht
abgelaufen.

Auch verstehe ich nicht, wieso mail.xxx.yy:143 reklamiert dass das
Zertifikat ungültig sei, und nicht  mail.xxx.yy.


danke für Eure Hinweise

Robert

Reply | Threaded
Open this post in threaded view
|

Re: "plötzlich" meldungen das mail.xx.yy:143 ungültiges zertifikat hat

André Peters
Hi,

vielleicht ist der Dovecot Dienst nur nicht neugestartet. Und verwendest
du einen Reverse Proxy?

André

------ Originalnachricht ------
Von: "robert rottermann" <[hidden email]>
An: [hidden email]
Gesendet: 12.06.2019 14:58:36
Betreff: "plötzlich" meldungen das mail.xx.yy:143 ungültiges zertifikat
hat

>Hoi zäme,
>
>
>ich bekomme seit einigen Tagen massenhaft  Meldungen, mein (letsencrypt) Zertifikat auf mail.xx.yy:143 sei abgelaufen.
>
>Wenn ich jedoch auf den Server gehe, und mit certbot renew zu erneuern versuche, bekomme ich eine Meldung, das Zertifikat sei noch nicht abgelaufen.
>
>Auch verstehe ich nicht, wieso mail.xxx.yy:143 reklamiert dass das Zertifikat ungültig sei, und nicht  mail.xxx.yy.
>
>
>danke für Eure Hinweise
>
>Robert
>

Reply | Threaded
Open this post in threaded view
|

Re: [ext] "plötzlich" meldungen das mail.xx.yy:143 ungültiges zertifikat hat

Ralf Hildebrandt
In reply to this post by robert rottermann-2
* robert rottermann <[hidden email]>:
> Hoi zäme,
>
>
> ich bekomme seit einigen Tagen massenhaft  Meldungen, mein (letsencrypt)
> Zertifikat auf mail.xx.yy:143 sei abgelaufen.
>
> Wenn ich jedoch auf den Server gehe, und mit certbot renew zu erneuern
> versuche, bekomme ich eine Meldung, das Zertifikat sei noch nicht
> abgelaufen.

Vielleicht nutzt port 143 nicht dasselbe Zertifikat wie der Rest der
Systems
 
> Auch verstehe ich nicht, wieso mail.xxx.yy:143 reklamiert dass das
> Zertifikat ungültig sei, und nicht  mail.xxx.yy.

IMAP?

--
Ralf Hildebrandt
  Geschäftsbereich IT | Abteilung Netzwerk
  Charité - Universitätsmedizin Berlin
  Campus Benjamin Franklin
  Hindenburgdamm 30 | D-12203 Berlin
  Tel. +49 30 450 570 155 | Fax: +49 30 450 570 962
  [hidden email] | https://www.charite.de
           
Reply | Threaded
Open this post in threaded view
|

Re: "plötzlich" meldungen das mail.xx.yy:143 ungültiges zertifikat hat

Florian Ruhnke
In reply to this post by robert rottermann-2
Moin,

mein erster Gedanke: Da hat sich das Zertifikat geändert (renew) und Postfix weiß nix davon.
Ich habe z.B. bei CertBot noch ein "--renew-hook postfix reload" hinten dran, weil Postfix geänderte Zertifikate während der Laufzeit nicht automatisch erkennt.
Schau mal, ob ein "postfix reload" das Problem behebt.

> Auch verstehe ich nicht, wieso mail.xxx.yy:143 reklamiert dass das Zertifikat ungültig sei, und
> nicht  mail.xxx.yy.

Würde dafür sprechen: Der Webserver kennt das neue Zertifikat, der Mailserver (noch) nicht.

Gruß
Florian

12. Juni 2019 14:58, "robert rottermann" <[hidden email]> schrieb:

> Hoi zäme,
>
> ich bekomme seit einigen Tagen massenhaft  Meldungen, mein (letsencrypt) Zertifikat auf
> mail.xx.yy:143 sei abgelaufen.
>
> Wenn ich jedoch auf den Server gehe, und mit certbot renew zu erneuern versuche, bekomme ich eine
> Meldung, das Zertifikat sei noch nicht abgelaufen.
>
> Auch verstehe ich nicht, wieso mail.xxx.yy:143 reklamiert dass das Zertifikat ungültig sei, und
> nicht  mail.xxx.yy.
>
> danke für Eure Hinweise
>
> Robert
Reply | Threaded
Open this post in threaded view
|

Re: "plötzlich" meldungen das mail.xx.yy:143 ungültiges zertifikat hat

Alexander Dalloz
Am 12.06.2019 um 19:16 schrieb Florian Ruhnke:
> Moin,
>
> mein erster Gedanke: Da hat sich das Zertifikat geändert (renew) und Postfix weiß nix davon.
> Ich habe z.B. bei CertBot noch ein "--renew-hook postfix reload" hinten dran, weil Postfix geänderte Zertifikate während der Laufzeit nicht automatisch erkennt.
> Schau mal, ob ein "postfix reload" das Problem behebt.

Port 143 hat aber mit SMTP nichts zu tun. wie im Thread bereits
angedeutet, das Setup des IMAP Servers überprüfen.

echo QUIT | openssl s_client -connect <host>:143 -starttls imap

und dann den Output lesen.

Alexander
Reply | Threaded
Open this post in threaded view
|

Re: "plötzlich" meldungen das mail.xx.yy:143 ungültiges zertifikat hat

Christian Schmidt
In reply to this post by robert rottermann-2
Moin,

robert rottermann, 12.06.19:
> ich bekomme seit einigen Tagen massenhaft  Meldungen, mein (letsencrypt)
> Zertifikat auf mail.xx.yy:143 sei abgelaufen.

Welcher Hostname ist denn im Zertifikat hinterlegt?
mail.xx.yy oder
mail.xx.yy:143?

Ist da womöglich irgendwo nur ein "falscher" Hostname (eben mit ":143"
hintendran) eingetragen?

Mit freundlichen Grüßen
Christian Schmidt

--
No signature available.


smime.p7s (7K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: [ext] Re: "plötzlich" meldungen das mail.xx.yy:143 ungültiges zertifikat hat

Ralf Hildebrandt
In reply to this post by Florian Ruhnke
* Florian Ruhnke <[hidden email]>:
> Moin,
>
> mein erster Gedanke: Da hat sich das Zertifikat geändert (renew) und Postfix weiß nix davon.
> Ich habe z.B. bei CertBot noch ein "--renew-hook postfix reload" hinten dran, weil Postfix geänderte Zertifikate während der Laufzeit nicht automatisch erkennt.
> Schau mal, ob ein "postfix reload" das Problem behebt.

Oder eher dovecot reload

--
Ralf Hildebrandt
  Geschäftsbereich IT | Abteilung Netzwerk
  Charité - Universitätsmedizin Berlin
  Campus Benjamin Franklin
  Hindenburgdamm 30 | D-12203 Berlin
  Tel. +49 30 450 570 155 | Fax: +49 30 450 570 962
  [hidden email] | https://www.charite.de