trying to hunt down meaning of warning in log file

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

trying to hunt down meaning of warning in log file

Fazzina, Angelo

Hi, I run RHEL6.9, postfix 2.6.6, and  openssl 1.0.1e-57.el6.

 

I found this in the logs

Jul 28 08:39:32 mail6 postfix/smtpd[22622]: connect from uconn.illiad.oclc.org[206.107.43.160]

Jul 28 08:39:32 mail6 postfix/smtpd[22622]: SSL_accept error from uconn.illiad.oclc.org[206.107.43.160]: -1

Jul 28 08:39:32 mail6 postfix/smtpd[22622]: warning: TLS library problem: 22622:error:1408F119:SSL routines:SSL3_GET_RECORD:decryption failed or bad record mac:s3_pkt.c:486:

Jul 28 08:39:32 mail6 postfix/smtpd[22622]: lost connection after CONNECT from uconn.illiad.oclc.org[206.107.43.160]

Jul 28 08:39:32 mail6 postfix/smtpd[22622]: disconnect from uconn.illiad.oclc.org[206.107.43.160]

 

I have this from the senders logs

2017-07-28 08:39:32,835 [5] WARN  AtlasSystems.Mail.MailClient - Error sending message 779696

2017-07-28 08:39:32,835 [5] WARN  AtlasSystems.ILLiad.SystemManager.Email - Error delivering message 779696: Remote host disconnected during SSL negotiation.

2017-07-28 08:39:32,835 [5] INFO  AtlasSystems.ILLiad.SystemManager.Email - Message 779696 failed. Message Note: Remote host disconnected during SSL negotiation.

2017-07-28 08:39:32,835 [5] INFO  AtlasSystems.ILLiad.SystemManager.Email - Message 779696 Retry Attempts: 5

2017-07-28 08:39:32,835 [5] INFO  AtlasSystems.ILLiad.SystemManager.Email - Message 779696 has permanently failed.

2017-07-28 08:39:32,835 [5] INFO  AtlasSystems.Mail.MailMessage - Update Email Message [779696]

 

 

I tried to Google

TLS library problem: 22622:error:1408F119:SSL routines:SSL3_GET_RECORD:decryption failed or bad record mac:s3_pkt.c:486:

Only got 5 hits.

According to a post about Debian Openssl 1.0.1.e gets rid of the error, but reading the whole thread the guys says it doesn’t fix it.

According to another there was a buffer length exceeded.

And from yet another I think I read about data packets mixing encrypted data with non encrypted data, possibly based on cipher chosen and hand shake fails, so connection drops…?

 

I’ll try to search some RedHat sites.

If anyone has any breadcrumbs that would be great !

Thanks.

-ALF

 

 

-Angelo Fazzina

Operating Systems Programmer / Analyst

University of Connecticut,  UITS, SSG, Server Systems

860-486-9075

 

Loading...