unused parameter: policy-spf_time_limit=3600s

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

unused parameter: policy-spf_time_limit=3600s

Juan Pablo
Hello,

I am having a new Ubuntu 14.04 server set up with postfix.  When using
postfix check I am seeing warning about unused parameter

   /usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter:
policy-spf_time_limit=3600s
   /usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter:
policy-spf_time_limit=3600s
   /usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter:
policy-spf_time_limit=3600s
   ....repeat 10 more time....

policy-spf_time_limit = 3600s

is defined in my main.cf at the bottom

I have the following installed:

   # dpkg -l | grep postfix
   ii  postfix   2.11.0-1ubuntu1   amd64        High-performance mail
transport agent
   ii  postfix-pcre  2.11.0-1ubuntu1      amd64        PCRE map support
for Postfix
   ii  postfix-policyd-spf-python 1.2-1       all          Postfix policy
server for SPF checking

Can any person tell me if this entry has been depreciated or if it is
some other problem?

Thanks

JP
Reply | Threaded
Open this post in threaded view
|

Re: unused parameter: policy-spf_time_limit=3600s

Scott Kitterman-4
On Saturday, April 18, 2015 03:48:47 PM Juan Pablo wrote:

> Hello,
>
> I am having a new Ubuntu 14.04 server set up with postfix.  When using
> postfix check I am seeing warning about unused parameter
>
>    /usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter:
> policy-spf_time_limit=3600s
>    /usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter:
> policy-spf_time_limit=3600s
>    /usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter:
> policy-spf_time_limit=3600s
>    ....repeat 10 more time....
>
> policy-spf_time_limit = 3600s
>
> is defined in my main.cf at the bottom
>
> I have the following installed:
>
>    # dpkg -l | grep postfix
>    ii  postfix   2.11.0-1ubuntu1   amd64        High-performance mail
> transport agent
>    ii  postfix-pcre  2.11.0-1ubuntu1      amd64        PCRE map support
> for Postfix
>    ii  postfix-policyd-spf-python 1.2-1       all          Postfix policy
> server for SPF checking
>
> Can any person tell me if this entry has been depreciated or if it is
> some other problem?

It means that the parameter is no longer in use.  In this case it usually
means either you're no longer using the SPF policy server or the master.cf is
using a different name for the process.

Also, you might want to consider upgrading to 1.3.1 in trusty-backports since
it's been updated for the changes in RFC 7208.

Scott K